summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/edid-decode/edid-decode-9999.ebuild')
-rw-r--r--sys-apps/edid-decode/edid-decode-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/edid-decode/edid-decode-9999.ebuild b/sys-apps/edid-decode/edid-decode-9999.ebuild
new file mode 100644
index 000000000000..a46948f8178a
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 toolchain-funcs
+
+EGIT_REPO_URI="https://git.linuxtv.org/${PN}.git"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+
+KEYWORDS=""
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}