summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elfix/elfix-9999.ebuild')
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index a7a57400096c..b852f0585a0b 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,30 +1,26 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo"
+DESCRIPTION="Suite of tools to work with ELF objects on Hardened Gentoo"
HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
https://dev.gentoo.org/~blueness/elfix/"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
-IUSE="+ptpax +xtpax"
-
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
+IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
-
# These only work with a properly configured PaX kernel
-RESTRICT="test"
+RESTRICT="!test? ( test ) test"
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
@@ -41,8 +37,9 @@ src_prepare() {
}
src_configure() {
- rm -f "${S}/scripts/setup.py"
- econf --disable-tests \
+ rm -f "${S}/scripts/setup.py" || die
+ econf \
+ $(use_enable test tests) \
$(use_enable ptpax) \
$(use_enable xtpax)
}