summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild')
-rw-r--r--sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild b/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild
deleted file mode 100644
index 5707a104f427..000000000000
--- a/sys-apps/elivepatch-server/elivepatch-server-0.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Live patch building server with RESTFul Api for elivepatch-client"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
-SRC_URI="https://github.com/aliceinwire/elivepatch-server/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-restful[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_install_all() {
- newinitd init/elivepatch.init ${PN}
- newconfd init/elivepatch.confd ${PN}
- distutils-r1_python_install_all
-}