summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/findutils/findutils-4.6.0-r1.ebuild')
-rw-r--r--sys-apps/findutils/findutils-4.6.0-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/sys-apps/findutils/findutils-4.6.0-r1.ebuild b/sys-apps/findutils/findutils-4.6.0-r1.ebuild
deleted file mode 100644
index 4f3967c9d460..000000000000
--- a/sys-apps/findutils/findutils-4.6.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-inherit eutils flag-o-matic toolchain-funcs python-any-r1
-
-DESCRIPTION="GNU utilities for finding files"
-HOMEPAGE="https://www.gnu.org/software/findutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls selinux static test"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Don't build or install locate because it conflicts with slocate,
- # which is a secure version of locate. See bug 18729
- sed -i '/^SUBDIRS/s/locate//' Makefile.in
-
- # Newer C libraries omit this include from sys/types.h.
- # https://lists.gnu.org/archive/html/bug-gnulib/2016-03/msg00018.html
- sed -i \
- '/include.*config.h/a#ifdef MAJOR_IN_SYSMACROS\n#include <sys/sysmacros.h>\n#endif\n' \
- gl/lib/mountlist.c || die
-
- epatch "${FILESDIR}"/${P}-gnulib-mb.patch #576818
- epatch "${FILESDIR}"/${P}-gnulib-S_MAGIC_NFS.patch #580032
- epatch "${FILESDIR}"/${P}-glibc228.patch #663242
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- program_prefix=$(usex userland_GNU '' g)
- econf \
- --with-packager="Gentoo" \
- --with-packager-version="${PVR}" \
- --with-packager-bug-reports="https://bugs.gentoo.org/" \
- --program-prefix=${program_prefix} \
- $(use_enable nls) \
- $(use_with selinux) \
- --libexecdir='$(libdir)'/find
-}
-
-src_compile() {
- # We don't build locate, but the docs want a file in there.
- emake -C locate dblocation.texi
- default
-}