summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
new file mode 100644
index 000000000000..0023f2d5ed9d
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2013-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd udev
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+fi
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="acct-group/floppy
+ acct-group/usb
+ >=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
+ --with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ udevdir="${EPREFIX}$(get_udevdir)"
+ )
+ econf "${myconf[@]}"
+}