summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/grep/grep-3.3-r1.ebuild')
-rw-r--r--sys-apps/grep/grep-3.3-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-apps/grep/grep-3.3-r1.ebuild b/sys-apps/grep/grep-3.3-r1.ebuild
deleted file mode 100644
index 52fe9c4bbd14..000000000000
--- a/sys-apps/grep/grep-3.3-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="GNU regular expression matcher"
-HOMEPAGE="https://www.gnu.org/software/grep/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
- mirror://gentoo/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls pcre static"
-
-LIB_DEPEND="pcre? ( >=dev-libs/libpcre-7.8-r1[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- nls? ( virtual/libintl )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- static? ( ${LIB_DEPEND} )"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-src_prepare() {
- sed -i \
- -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
- -e "s:@grep@:${EPREFIX}/bin/grep:" \
- src/egrep.sh || die #523898
-
- default
-}
-
-src_configure() {
- use static && append-ldflags -static
- # don't link against libsigsegv even when available
- export ac_cv_libsigsegv=no
- # Always use pkg-config to get lib info for pcre.
- export ac_cv_search_pcre_compile=$(
- usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
- )
- econf \
- --bindir="${EPREFIX}"/bin \
- $(use_enable nls) \
- $(use_enable pcre perl-regexp)
-}