summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hbaapi/hbaapi-2.2.ebuild')
-rw-r--r--sys-apps/hbaapi/hbaapi-2.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-apps/hbaapi/hbaapi-2.2.ebuild b/sys-apps/hbaapi/hbaapi-2.2.ebuild
deleted file mode 100644
index 9086d5cb1f00..000000000000
--- a/sys-apps/hbaapi/hbaapi-2.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-MY_PN="${PN}_src"
-MY_P="${MY_PN}_${PV}"
-DESCRIPTION="The Host Bus Adapter API for managing Fibre Channel Host Bus Adapters"
-HOMEPAGE="http://hbaapi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz
- mirror://gentoo/${P}.Makefile.gz"
-
-LICENSE="SNIA"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- mv "${WORKDIR}"/${P}.Makefile "${S}"/Makefile
-
- sed -i -e "s/-g -c/${CFLAGS} -c/" \
- -e "s/-shared/\0 ${LDFLAGS}/" \
- Makefile || die
-
- epatch "${FILESDIR}"/${P}-qa.patch
-}
-
-src_compile() {
- # not parallel safe!
- emake -j1 CC="$(tc-getCC)" all
-}
-
-src_install() {
- into /usr
- dolib.so libHBAAPI.so
- dosbin hbaapitest
- insinto /etc
- doins "${FILESDIR}"/hba.conf
- dodoc readme.txt
-}