summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/help2man/help2man-1.45.1.ebuild')
-rw-r--r--sys-apps/help2man/help2man-1.45.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/help2man/help2man-1.45.1.ebuild b/sys-apps/help2man/help2man-1.45.1.ebuild
new file mode 100644
index 000000000000..bb1e88217e30
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.45.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND=${RDEPEND}
+
+DOCS="debian/changelog NEWS README THANKS" #385753
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.36.4-respect-LDFLAGS.patch \
+ "${FILESDIR}"/${PN}-1.38.4-linguas.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}