summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwinfo')
-rw-r--r--sys-apps/hwinfo/Manifest3
-rw-r--r--sys-apps/hwinfo/hwinfo-21.23.ebuild56
-rw-r--r--sys-apps/hwinfo/hwinfo-21.4.ebuild63
-rw-r--r--sys-apps/hwinfo/hwinfo-23.2-r1.ebuild53
-rw-r--r--sys-apps/hwinfo/metadata.xml9
5 files changed, 60 insertions, 124 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index 7a06146360c6..c57d4ab8f8f3 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -1,2 +1 @@
-DIST hwinfo-21.23-1.2.src.rpm 844672 BLAKE2B 33cfd68c06081d76b33243474b9a72cc5994c749ff57b7fc4f36c88627707068fb86d4825bae66e4e08f730dc8849264f5f31f8717f28400b3d54302ac12b1eb SHA512 d25c955fa5620268a34a857916e0bdbbdb92f8e092735ac453e7bacc6476e00047c9ccef3a5275e5d50cc354bf9e3cffef57af519dc885d0afd3d161ab426629
-DIST hwinfo-21.4-1.1.src.rpm 781525 BLAKE2B 83c6d0b3d15a7b4354223eef8b976643ec6520842007ce6fb06534360a8994d4aac0975eba059275910f59391e7069b0166b69301006ea78ca4b74c6aefbde7c SHA512 bccac7749751924e1e1a8005e6fd783da7114926b6d9b9a1247b3b26dd680848eb2b85b368c312d08b444c8d7b75036d249daf33afc5b7efbbcc09bfbad4b340
+DIST hwinfo-23.2.tar.gz 1237565 BLAKE2B 86c085c0b58b967f94ded3db4975cd824f69908b3b7fc1d27e2d51cb0e570969a7af2274f55d6eb1d871e1422016deb8007c76199be441ad94486ab18f9bff7a SHA512 86096455cc58ecdd3be4306d61beaea02da39b8ee3b2a99966d4aaf022e276616329ca82550d7903e2aed9b1723a99b2305617fb85df21c1d2024ce46b447af3
diff --git a/sys-apps/hwinfo/hwinfo-21.23.ebuild b/sys-apps/hwinfo/hwinfo-21.23.ebuild
deleted file mode 100644
index 97cc8c3e0a74..000000000000
--- a/sys-apps/hwinfo/hwinfo-21.23.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib rpm toolchain-funcs
-
-DESCRIPTION="Hardware detection tool used in SuSE Linux"
-HOMEPAGE="https://www.opensuse.org/"
-SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-1.2.src.rpm"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- amd64? ( dev-libs/libx86emu )
- x86? ( dev-libs/libx86emu )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- >=sys-kernel/linux-headers-2.6.17"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- # Respect AR variable.
- sed -i \
- -e 's:ar r:$(AR) r:' \
- src/{,isdn,ids,smp,hd}/Makefile || die
-
- # Respect LDFLAGS.
- sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
-
- # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
- sed -i \
- -e 's:make:$(MAKE):' \
- -e 's:-pipe -g::' \
- -e 's:LDFLAGS.*=:LDFLAGS +=:' \
- Makefile{,.common} || die
- default
-}
-
-src_compile() {
- tc-export AR
- emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
-}
-
-src_install() {
- emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
-
- dodoc changelog README*
- doman doc/*.{1,8}
- insinto /usr/share/doc/${PF}/examples
- doins doc/example*.c
-}
diff --git a/sys-apps/hwinfo/hwinfo-21.4.ebuild b/sys-apps/hwinfo/hwinfo-21.4.ebuild
deleted file mode 100644
index a63b0e33b3f5..000000000000
--- a/sys-apps/hwinfo/hwinfo-21.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib rpm toolchain-funcs
-
-DESCRIPTION="hardware detection tool used in SuSE Linux"
-HOMEPAGE="https://www.opensuse.org/"
-SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-1.1.src.rpm"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- amd64? ( dev-libs/libx86emu )
- x86? ( dev-libs/libx86emu )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- >=sys-kernel/linux-headers-2.6.17"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_prepare() {
- # Respect AR variable.
- sed -i \
- -e 's:ar r:$(AR) r:' \
- src/{,isdn,ids,smp,hd}/Makefile || die
-
- # Avoid -I directories for dbus because HAL is obsolete.
- sed -i -e '/CFLAGS/d' src/hd/Makefile || die
- # Respect LDFLAGS.
- sed -i -e 's:$(CC) -shared:& $(LDFLAGS):' src/Makefile || die
- sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
-
- # Use linux/pci.h directly. #506876
- sed -i \
- -e '/#include.*sys\/pci.h/s:sys/pci.h:linux/pci.h:' \
- src/hd/*.c || die
-
- # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
- sed -i \
- -e 's:make:$(MAKE):' \
- -e 's:-pipe -g::' \
- -e 's:LDFLAGS.*=:LDFLAGS +=:' \
- Makefile{,.common} || die
-}
-
-src_compile() {
- tc-export AR
- emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
-}
-
-src_install() {
- emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
-
- dodoc changelog README
- doman doc/*.{1,8}
- insinto /usr/share/doc/${PF}/examples
- doins doc/example*.c
-}
diff --git a/sys-apps/hwinfo/hwinfo-23.2-r1.ebuild b/sys-apps/hwinfo/hwinfo-23.2-r1.ebuild
new file mode 100644
index 000000000000..7426bb0ccfdc
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-23.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~loong ppc ~riscv x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="amd64? ( dev-libs/libx86emu:= )
+ x86? ( dev-libs/libx86emu:= )"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.17"
+BDEPEND="app-alternatives/lex"
+
+src_prepare() {
+ default
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ Makefile{,.common} || die
+ rm -f git2log || die
+}
+
+src_compile() {
+ emake -j1 AR="$(tc-getAR)" CC="$(tc-getCC)" HWINFO_VERSION="${PV}" \
+ RPM_OPT_FLAGS="${CFLAGS}" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}
diff --git a/sys-apps/hwinfo/metadata.xml b/sys-apps/hwinfo/metadata.xml
index 483ee9fe5899..d4df3edaa615 100644
--- a/sys-apps/hwinfo/metadata.xml
+++ b/sys-apps/hwinfo/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>robbat2@gentoo.org</email>
- <name>Robin H. Johnson</name>
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">openSUSE/hwinfo</remote-id>
+ </upstream>
</pkgmetadata>