summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/inxi/inxi-2.2.14.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.2.14.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.2.14.ebuild b/sys-apps/inxi/inxi-2.2.14.ebuild
new file mode 100644
index 000000000000..2e9a941885ca
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.2.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A newer, better system information script for irc, administration, and system troubleshooters."
+HOMEPAGE="http://code.google.com/p/inxi/"
+SRC_URI="https://inxi.googlecode.com/svn/tarballs/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=app-shells/bash-3.0
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/pciutils
+ sys-process/procps
+ sys-apps/sed
+ "
+
+S=${WORKDIR}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1.gz
+}
+
+pkg_postinst() {
+ einfo "To view a short or full system information."
+ einfo "inxi -b for short information."
+ einfo "inxi -F for full information."
+ einfo "inxi also provides verbose levels '-v1 to -v7'."
+ einfo "inxi -h for help."
+}