summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild b/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild
new file mode 100644
index 000000000000..619a8b5cb19b
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.4_p20161104-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT=89e18d245bc34fc5be5f5baddac2ccd8106be050 #because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ "
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin "${PN}"
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+}