summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mawk/mawk-1.3.4_p20140914.ebuild')
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20140914.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/mawk/mawk-1.3.4_p20140914.ebuild b/sys-apps/mawk/mawk-1.3.4_p20140914.ebuild
new file mode 100644
index 000000000000..99b3cb942f19
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20140914.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+MY_P=${P/_p/-}
+DESCRIPTION="an (often faster than gawk) awk-interpreter"
+HOMEPAGE="http://invisible-island.net/mawk/mawk.html"
+SRC_URI="ftp://invisible-island.net/mawk/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+
+RDEPEND="app-eselect/eselect-awk"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+src_prepare() {
+ tc-export BUILD_CC
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ eselect awk update ifunset
+}
+
+pkg_postrm() {
+ eselect awk update ifunset
+}