summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/mcstrans/mcstrans-9999.ebuild')
-rw-r--r--sys-apps/mcstrans/mcstrans-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/sys-apps/mcstrans/mcstrans-9999.ebuild b/sys-apps/mcstrans/mcstrans-9999.ebuild
index 1fb74df9e673..bbd7a4cc0378 100644
--- a/sys-apps/mcstrans/mcstrans-9999.ebuild
+++ b/sys-apps/mcstrans/mcstrans-9999.ebuild
@@ -1,38 +1,35 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit toolchain-funcs
-MY_RELEASEDATE="20190315"
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
-MY_P="${P//_/-}"
-IUSE=""
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
+ S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi
-DESCRIPTION="SELinux context translation to human readable names"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
LICENSE="GPL-2"
SLOT="0"
DEPEND=">=sys-libs/libsepol-${PV}:=
>=sys-libs/libselinux-${PV}:=
- dev-libs/libpcre:=
+ dev-libs/libpcre2:=
>=sys-libs/libcap-1.10-r10:="
-RDEPEND="${DEPEND}
- !<sys-apps/policycoreutils-2.7_pre"
+RDEPEND="${DEPEND}"
src_prepare() {
default