summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/moar')
-rw-r--r--sys-apps/moar/Manifest6
-rw-r--r--sys-apps/moar/metadata.xml11
-rw-r--r--sys-apps/moar/moar-1.23.13.ebuild51
-rw-r--r--sys-apps/moar/moar-1.23.14.ebuild51
-rw-r--r--sys-apps/moar/moar-1.23.9.ebuild42
5 files changed, 161 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
new file mode 100644
index 000000000000..8e3ce72ca19e
--- /dev/null
+++ b/sys-apps/moar/Manifest
@@ -0,0 +1,6 @@
+DIST moar-1.23.13-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.23.13.tar.gz 2804565 BLAKE2B 01737fbc85e46fb87433bac2f2177562924a8ed2bd12ebd4e361f5a61723de112a0888b188992ae037e9d32303ede836a42d49920b6906acb1c6bf446d7e9a98 SHA512 a054cdf046f8e0e3b2afb949ad766e96ef6b18f5cd06a556af99f6f3b1af662a9e2b0bac49f791fe8eaf143616f2237080b48eeb9e90c595a59d9bed824f3238
+DIST moar-1.23.14-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c67dd6e692e456d5d98830fba93b3a17e5d3b3026c0f7ea10e3810db1f17ccb27b3cb704cff1c9bcbd267fbf68acbd SHA512 f12f2fa563b5170c8fe092f15476692815c2e0ab341d8becff504e5ded426efae5fc20697ef935ca5d037fa40abbfebbe5d0f59ac4e805e2d7d60e19070df3d4
+DIST moar-1.23.14.tar.gz 2804444 BLAKE2B 596ab44ac62d092895f1b211f946863d31b7bb9db00d2fdc26a3b3f5d3b8cfab290ee651ba1665584be1055633762dd3cbd971bfd0121ca5c923fa8fc55f4c36 SHA512 b67a535d8dc4ff79966b3d75aaa4c17acf2f648327443e4393fedd42f20dcd147ae8cb53ae5bf795de54639e3ed599f3c7c434df6556d4b3a08171b0aeb3f3c9
+DIST moar-1.23.9-deps.tar.xz 37188500 BLAKE2B a5c92f8e56d4c7588265132f33089f1086fb7a14b1d1023caf7594cbda16772776751a80d44f451a9c5c765bd03d25687a63b5a00c4a50603b4598162920d840 SHA512 44c924339dbde95b647c464a00382786dfd8adfc72f307a9df63ed39f85fefe76260fde082a39738fb97c571217e8d591bdeada054dbe75ed56aa0156e7cf2fa
+DIST moar-1.23.9.tar.gz 2804191 BLAKE2B d5663fedd70fc80d70a206c276ece6ec11da4f4b4dc396a3e11b1fb8edd5bd9f3395e943158c4bb297b5ebfeecd8f61bdbaaff79e78c4a89458f1b1a02db0e71 SHA512 9ab4a3e49b66b39f642b6a1f882c0980a4e755e3e127ca37d1319615ae836fe3250676a8c0e95ccd0f8e714357df5dc00235bf67be6097a7b2811f0e3bf02e9f
diff --git a/sys-apps/moar/metadata.xml b/sys-apps/moar/metadata.xml
new file mode 100644
index 000000000000..da115d6b24cf
--- /dev/null
+++ b/sys-apps/moar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">walles/moar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/moar/moar-1.23.13.ebuild b/sys-apps/moar/moar-1.23.13.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.13.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}
diff --git a/sys-apps/moar/moar-1.23.14.ebuild b/sys-apps/moar/moar-1.23.14.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.14.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}
diff --git a/sys-apps/moar/moar-1.23.9.ebuild b/sys-apps/moar/moar-1.23.9.ebuild
new file mode 100644
index 000000000000..588769858549
--- /dev/null
+++ b/sys-apps/moar/moar-1.23.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}