summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/osinfo-db/osinfo-db-20231215.ebuild')
-rw-r--r--sys-apps/osinfo-db/osinfo-db-20231215.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db/osinfo-db-20231215.ebuild b/sys-apps/osinfo-db/osinfo-db-20231215.ebuild
new file mode 100644
index 000000000000..f2ac1ce4693f
--- /dev/null
+++ b/sys-apps/osinfo-db/osinfo-db-20231215.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="osinfo database files"
+HOMEPAGE="https://libosinfo.org/ https://gitlab.com/libosinfo/osinfo-db"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ~ppc ppc64 ~riscv ~sparc x86"
+
+BDEPEND="sys-apps/osinfo-db-tools"
+
+# we don't depend on intltool here, contrary to README, as the tarball already
+# contains the processed results with translations in XML files
+
+src_unpack() { :; }
+
+src_install() {
+ osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
+}