summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pick/pick-3.0.1.ebuild')
-rw-r--r--sys-apps/pick/pick-3.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/pick/pick-3.0.1.ebuild b/sys-apps/pick/pick-3.0.1.ebuild
new file mode 100644
index 000000000000..15898cb11a03
--- /dev/null
+++ b/sys-apps/pick/pick-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="a fuzzy search tool for the command-line"
+HOMEPAGE="https://github.com/mptre/pick"
+SRC_URI="https://github.com/mptre/pick/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ # not autoconf
+ ./configure || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" BINDIR=/usr/bin MANDIR=/usr/share/man install
+ dodoc CHANGELOG.md
+}