summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/qdirstat')
-rw-r--r--sys-apps/qdirstat/Manifest2
-rw-r--r--sys-apps/qdirstat/metadata.xml13
-rw-r--r--sys-apps/qdirstat/qdirstat-1.4.ebuild37
-rw-r--r--sys-apps/qdirstat/qdirstat-1.9.ebuild55
4 files changed, 63 insertions, 44 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 3dcad4c52891..3dd12d47b464 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1 +1 @@
-DIST qdirstat-1.4.tar.gz 2534241 BLAKE2B 70b84376a949ab3d74879bc78dac9d41c592ee9a4c60d27ad9d85ab09378f85a65209c78f7030f76e86e8e418803eef5ed1dadb07a1058ec38c13d753f6e3e61 SHA512 5711a78297f4224e4471ac14d8e42ee9ac746cc31315ff894dafa1db578eff4ff2a5c62edc525a49c523154a0de402f878200d96601c7924bf0273f0eac9ab74
+DIST qdirstat-1.9.tar.gz 9529866 BLAKE2B 3beb40381bf21f04651dcdab27086860ce428fed1e08e5ef6ca2f5e6048b56890554e29aa29db72f1869c7d7b94a964445cb93679d8dcaa4d38e6c24e07af28f SHA512 f70c5ed86daca8f2f081afec213908f51b621f043173f7906903bcf9e955d67c5906a2588622f7c57d753e6f839ed061420c0cdb76168c7b9d70ddf64f0f23ff
diff --git a/sys-apps/qdirstat/metadata.xml b/sys-apps/qdirstat/metadata.xml
index 8439819f2f80..ba245f43a2e0 100644
--- a/sys-apps/qdirstat/metadata.xml
+++ b/sys-apps/qdirstat/metadata.xml
@@ -1,13 +1,13 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>dracwyrm@gentoo.org</email>
- <name>Jonathan Scruggs</name>
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
</maintainer>
<longdescription>
- Qt-based directory statistics: KDirStat without any KDE -- from
- the author of the original KDirStat.
+ Qt-based directory statistics: KDirStat without any KDE,
+ from the author of the original KDirStat.
QDirStat is a graphical application to show where your disk space
has gone and to help you to clean it up.
@@ -18,6 +18,7 @@
and other Unix-like systems.
</longdescription>
<upstream>
+ <bugs-to>https://github.com/shundhammer/qdirstat/issues</bugs-to>
<remote-id type="github">shundhammer/qdirstat</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-apps/qdirstat/qdirstat-1.4.ebuild b/sys-apps/qdirstat/qdirstat-1.4.ebuild
deleted file mode 100644
index c7c59c77ebdb..000000000000
--- a/sys-apps/qdirstat/qdirstat-1.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils qmake-utils xdg-utils
-
-DESCRIPTION="Qt app to show where your disk space has gone and to help you clean it up"
-HOMEPAGE="https://github.com/shundhammer/qdirstat"
-SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-qt/qtgui:5
- dev-qt/qtcore:5
- dev-qt/qtwidgets:5"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- eqmake5
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/sys-apps/qdirstat/qdirstat-1.9.ebuild b/sys-apps/qdirstat/qdirstat-1.9.ebuild
new file mode 100644
index 000000000000..729da35e96e9
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of doc path
+ sed -e "/doc.path/s/${PN}/${PF}/" -i doc/doc.pro doc/stats/stats.pro || die
+
+ # Don't install compressed man pages
+ sed -e '/gzip/d' -e 's/.gz//g' -i man/man.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}