summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rename/rename-1.3-r1.ebuild')
-rw-r--r--sys-apps/rename/rename-1.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/rename/rename-1.3-r1.ebuild b/sys-apps/rename/rename-1.3-r1.ebuild
new file mode 100644
index 000000000000..0e3e57632631
--- /dev/null
+++ b/sys-apps/rename/rename-1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="tool for easily renaming files"
+HOMEPAGE="http://rename.sourceforge.net/"
+SRC_URI="http://${PN}/sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/s:-O3:@CFLAGS@:' \
+ -e '/strip /s:.*::' \
+ Makefile.in || die
+ epatch "${FILESDIR}"/${P}-rename.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ tc-export CC
+}
+
+src_install() {
+ newbin rename renamexm
+ newman rename.1 renamexm.1
+ dodoc README ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "This has been renamed to 'renamexm' to avoid"
+ ewarn "a naming conflict with sys-apps/util-linux."
+}