summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/selinux-python/selinux-python-9999.ebuild')
-rw-r--r--sys-apps/selinux-python/selinux-python-9999.ebuild65
1 files changed, 42 insertions, 23 deletions
diff --git a/sys-apps/selinux-python/selinux-python-9999.ebuild b/sys-apps/selinux-python/selinux-python-9999.ebuild
index eb75834f5ef4..20a1fea452bf 100644
--- a/sys-apps/selinux-python/selinux-python-9999.ebuild
+++ b/sys-apps/selinux-python/selinux-python-9999.ebuild
@@ -1,21 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python{3_5,3_6} )
-PYTHON_REQ_USE="xml"
+EAPI=7
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
inherit python-r1 toolchain-funcs
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20190315"
-SEPOL_VER="${PV}"
-SELNX_VER="${PV}"
-SEMNG_VER="${PV}"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="SELinux core utilities"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
@@ -23,25 +16,31 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN#selinux-}"
+ S="${WORKDIR}/${P}/${PN#selinux-}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python]
- >=sys-libs/libsepol-${SEPOL_VER}:=
+RDEPEND=">=sys-libs/libselinux-${PV}:=[python]
+ >=sys-libs/libsemanage-${PV}:=[python(+)]
+ >=sys-libs/libsepol-${PV}:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
- dev-python/ipy[${PYTHON_USEDEP}]
- !dev-python/sepolgen
+ >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}]
${PYTHON_DEPS}"
-
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=sys-apps/secilc-${PV}
+ )"
src_prepare() {
default
@@ -59,6 +58,26 @@ src_compile() {
python_foreach_impl building
}
+src_test() {
+ testing() {
+ # The different subprojects have some interproject dependencies:
+ # - audit2allow depens on sepolgen
+ # - chcat depends on semanage
+ # and maybe others.
+ # Add all the modules of the individual subprojects to the
+ # PYTHONPATH, so they get actually found and used. In
+ # particular, already installed versions on the system are not
+ # used.
+ for dir in audit2allow chcat semanage sepolgen/src sepolicy ; do
+ PYTHONPATH="${BUILD_DIR}/${dir}:${PYTHONPATH}"
+ done
+ PYTHONPATH=${PYTHONPATH} \
+ emake -C "${BUILD_DIR}" \
+ test
+ }
+ python_foreach_impl testing
+}
+
src_install() {
installation() {
emake -C "${BUILD_DIR}" \