summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/stroke/stroke-0.1.3-r2.ebuild')
-rw-r--r--sys-apps/stroke/stroke-0.1.3-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-apps/stroke/stroke-0.1.3-r2.ebuild b/sys-apps/stroke/stroke-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..836231099315
--- /dev/null
+++ b/sys-apps/stroke/stroke-0.1.3-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Powerful tool to change file timestamps (including ctimes)"
+HOMEPAGE="https://stroke.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-missing-header.patch" )
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}