summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/texinfo/texinfo-4.13-r2.ebuild')
-rw-r--r--sys-apps/texinfo/texinfo-4.13-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/texinfo/texinfo-4.13-r2.ebuild b/sys-apps/texinfo/texinfo-4.13-r2.ebuild
new file mode 100644
index 000000000000..719b8051f0b1
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.13-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+RDEPEND="!=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-xz.patch #269742
+ touch doc/install-info.1 #354589
+ epatch "${FILESDIR}"/${P}-texi2dvi-regexp-range.patch #311885
+ epatch "${FILESDIR}"/${P}-accentenc-test.patch
+ # waiting to be sent upstream for my copyright assignment form to be
+ # ready - Flameeyes
+ epatch "${FILESDIR}"/${P}-docbook.patch
+ epatch "${FILESDIR}"/${P}-tinfo.patch #457556
+ # timestamps must be newer than configure.ac touched by ${P}-tinfo.patch
+ touch doc/{texi2dvi,texi2pdf,pdftexi2dvi}.1 #354589
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ # Make cross-compiler safe (#196041)
+ if tc-is-cross-compiler ; then
+ emake -C tools/gnulib/lib || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+ newdoc info/README README.info
+ newdoc makeinfo/README README.makeinfo
+}