summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/udevil')
-rw-r--r--sys-apps/udevil/Manifest3
-rw-r--r--sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch11
-rw-r--r--sys-apps/udevil/files/udevil-0.4.1-flags.patch46
-rw-r--r--sys-apps/udevil/files/udevil-0.4.3-flags.patch46
-rw-r--r--sys-apps/udevil/files/udevil-0.4.4-stat.patch11
-rw-r--r--sys-apps/udevil/metadata.xml16
-rw-r--r--sys-apps/udevil/udevil-0.4.1.ebuild71
-rw-r--r--sys-apps/udevil/udevil-0.4.3.ebuild71
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r1.ebuild73
-rw-r--r--sys-apps/udevil/udevil-0.4.4.ebuild72
10 files changed, 420 insertions, 0 deletions
diff --git a/sys-apps/udevil/Manifest b/sys-apps/udevil/Manifest
new file mode 100644
index 000000000000..0abb1d6eb7b7
--- /dev/null
+++ b/sys-apps/udevil/Manifest
@@ -0,0 +1,3 @@
+DIST udevil-0.4.1.tar.xz 299636 SHA256 2ade0860d549455c73447f9b0d661c333e6f7fabe01008bebdc3045500feb057 SHA512 e67a1645b859b2a11671b3c78d093596f7151aa6e30d28622ad1620633297edcf423823a472ead9c703c9de7a9768c59999ea0ed65578d7fd2975a1408c13fc6 WHIRLPOOL b690861bfa5661a49fe4b9194488364d4ac28266764a04a774bc593f5fdf81098e5c237553d80426165b0271c48a53e977160a3defcf68c78fe21134fb7d40fd
+DIST udevil-0.4.3.tar.gz 474453 SHA256 c49d2644baf87182c160550d708f75fe1253a2ceb749148e9148d7f1cfbc6209 SHA512 7fc04a8166d189dab73e7ef0ed8d9db6d98dc74c9ae41a9ce2ee1a29b34d3ca6379fce96e89a5cbc9a10bf88167934710827487fe59c9f7c438832bbefc16adf WHIRLPOOL 17e56ca0026deb24d5d00718b83fe9fe49437f6f037ee91075542c70f46b993f8060fc4ccc9a1bf54b8cff90fad8706f4cd72f1a37794c8f9ad0086ff86d3597
+DIST udevil-0.4.4.tar.gz 477254 SHA256 ad2fd8375bd62622718a04235e9772119459089938dbb78e657955e595822b7c SHA512 adce4916e06d1cc4965521abbcbc2901e53930691167f431cb18e28d3ef8bde740e95a6a5f40dfc58dfd7b4b661b4475d3dd2b6174a5d7a55ae7c65629b82327 WHIRLPOOL 6bd7b5e6792e9f556113260a86f1aa29b795a0d7ddc577f86fd286d2a95515ac32e80bdfc4677a1aa59b0efcbddd8e40eec83db4e63439e8d1fead6061b64bec
diff --git a/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch b/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch
new file mode 100644
index 000000000000..44da794b195b
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- udevil-0.4.1/configure.ac
++++ udevil-0.4.1/configure.ac
+@@ -1,7 +1,7 @@
+ AC_PREREQ(2.52)
+
+ AC_INIT(src/udevil.c)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_SRCDIR(src)
+ AM_INIT_AUTOMAKE(udevil, 0.4.1)
+
diff --git a/sys-apps/udevil/files/udevil-0.4.1-flags.patch b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
new file mode 100644
index 000000000000..166a4357e9f3
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
@@ -0,0 +1,46 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 21 19:33:04 UTC 2012
+Subject: build system
+
+ respect flags where possible
+
+--- configure.ac
++++ configure.ac
+@@ -18,26 +18,6 @@
+
+
+ dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+ AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+ case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+@@ -49,10 +29,6 @@
+ ;;
+ esac
+
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/files/udevil-0.4.3-flags.patch b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
new file mode 100644
index 000000000000..166a4357e9f3
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
@@ -0,0 +1,46 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 21 19:33:04 UTC 2012
+Subject: build system
+
+ respect flags where possible
+
+--- configure.ac
++++ configure.ac
+@@ -18,26 +18,6 @@
+
+
+ dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+ AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+ case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+@@ -49,10 +29,6 @@
+ ;;
+ esac
+
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/files/udevil-0.4.4-stat.patch b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
new file mode 100644
index 000000000000..22e41d467821
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
@@ -0,0 +1,11 @@
+Fixes bug #552072. Thanks Helmut Jarausch.
+--- src/device-info.h
++++ src/device-info.h
+@@ -14,6 +14,7 @@
+ #include <libudev.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <sys/stat.h>
+
+ // intltool
+ #include <glib/gi18n.h>
diff --git a/sys-apps/udevil/metadata.xml b/sys-apps/udevil/metadata.xml
new file mode 100644
index 000000000000..0bd37e4f04e2
--- /dev/null
+++ b/sys-apps/udevil/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>zlg@gentoo.org</email>
+ <name>Daniel Campbell</name>
+ </maintainer>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">IgnorantGuru/udevil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/udevil/udevil-0.4.1.ebuild b/sys-apps/udevil/udevil-0.4.1.ebuild
new file mode 100644
index 000000000000..e9a85143d218
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{flags,automake-1.13}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}
diff --git a/sys-apps/udevil/udevil-0.4.3.ebuild b/sys-apps/udevil/udevil-0.4.3.ebuild
new file mode 100644
index 000000000000..41dea7cf1953
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}
diff --git a/sys-apps/udevil/udevil-0.4.4-r1.ebuild b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..50e6751d3fee
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0:*
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # This works for 0.4.4 too, no sense copying the patch
+ epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ epatch "${FILESDIR}"/${P}-stat.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}
diff --git a/sys-apps/udevil/udevil-0.4.4.ebuild b/sys-apps/udevil/udevil-0.4.4.ebuild
new file mode 100644
index 000000000000..5023bba1eb28
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0:*
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # This works for 0.4.4 too, no sense copying the patch
+ epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ --enable-systemd
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}