summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/Manifest2
-rw-r--r--sys-apps/vbetool/files/vbetool-1.0-build.patch18
-rw-r--r--sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch7
-rw-r--r--sys-apps/vbetool/metadata.xml6
-rw-r--r--sys-apps/vbetool/vbetool-1.1.ebuild34
-rw-r--r--sys-apps/vbetool/vbetool-1.2.2.ebuild36
6 files changed, 45 insertions, 58 deletions
diff --git a/sys-apps/vbetool/Manifest b/sys-apps/vbetool/Manifest
index 4a22534a6505..fa7e83143dd4 100644
--- a/sys-apps/vbetool/Manifest
+++ b/sys-apps/vbetool/Manifest
@@ -1 +1 @@
-DIST vbetool-1.1.tar.gz 182826 BLAKE2B 6b30eb468e55bedd766161e373e042b5fdf38fd2926bfc8aeb94404350864e835d41642f19be155fcf9a8fbfdc8b4e237e742cabd00626db5e8d17e7c7c5cf6f SHA512 09d8713516f074fe8e901ab3e24aba7e8b9ddf459b3ee3394b7604e4489a70a27c6dc3604cf1284c49233dba908f00da746c583562af2bc93b6df8ff413efd96
+DIST vbetool-1.2.2.tar.xz 22032 BLAKE2B 0ab3263d347ad382c73265e08bb2d81468e1066212a282eee972f1e806a8cef94a0194878a8f2a113d3c139a58b9b18a8e3e6153ce868803bd74c3724e61d9d2 SHA512 658028e6fd1e1218c08a55de75009b6256f46dd22e259a5ab605d4686baf909688997882ba98ee7bee9b26b0dd334a38ddd7e63d8884626f8c3e0cedf87c4dea
diff --git a/sys-apps/vbetool/files/vbetool-1.0-build.patch b/sys-apps/vbetool/files/vbetool-1.0-build.patch
deleted file mode 100644
index 69d2f7b341ba..000000000000
--- a/sys-apps/vbetool/files/vbetool-1.0-build.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Index: vbetool-1.0/Makefile.am
-===================================================================
---- vbetool-1.0.orig/Makefile.am
-+++ vbetool-1.0/Makefile.am
-@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = foreign
-
- sbin_PROGRAMS = vbetool
-
--vbetool_LDADD = $(libdir)/libpci.a
-+vbetool_LDADD = -lpci -lz -lx86
-
- man_MANS = vbetool.1
- vbetool_SOURCES = vbetool.c $(x86)
-@@ -14,4 +14,3 @@ maintainer-clean-local:
- $(RM) Makefile.in aclocal.m4 config.h.in stamp-h.in configure
-
- AM_CFLAGS = -g -Wall -pedantic -std=gnu99
--AM_LDFLAGS = -lz -lx86
diff --git a/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch b/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch
new file mode 100644
index 000000000000..f3f4c36d0219
--- /dev/null
+++ b/sys-apps/vbetool/files/vbetool-1.2.2-libx86.patch
@@ -0,0 +1,7 @@
+Gentoo's libx86 package does not have a .pc file (adds -lx86 either way).
+--- a/configure.ac
++++ b/configure.ac
+@@ -38,3 +38,2 @@
+ # Checks for pkg-config packages
+-PKG_CHECK_MODULES(LIBX86, x86)
+
diff --git a/sys-apps/vbetool/metadata.xml b/sys-apps/vbetool/metadata.xml
index a6ab4e944256..aaab041e8885 100644
--- a/sys-apps/vbetool/metadata.xml
+++ b/sys-apps/vbetool/metadata.xml
@@ -1,11 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>robbat2@gentoo.org</email>
</maintainer>
-<maintainer type="project">
- <email>x11@gentoo.org</email>
- <name>X11</name>
-</maintainer>
</pkgmetadata>
diff --git a/sys-apps/vbetool/vbetool-1.1.ebuild b/sys-apps/vbetool/vbetool-1.1.ebuild
deleted file mode 100644
index fd6c4d5d9ce2..000000000000
--- a/sys-apps/vbetool/vbetool-1.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Run real-mode video BIOS code to alter hw state (i.e. reinitialize video card)"
-HOMEPAGE="http://www.codon.org.uk/~mjg59/vbetool/"
-SRC_URI="http://www.codon.org.uk/~mjg59/vbetool/download/vbetool-1.1.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
- sys-libs/zlib
- sys-apps/pciutils
- >=dev-libs/libx86-1.1-r1"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.0-build.patch )
-
-src_prepare() {
- default
-
- eaclocal # temp fix for #439614
- eautoreconf
-}
-
-src_configure() {
- econf --with-x86emu
-}
diff --git a/sys-apps/vbetool/vbetool-1.2.2.ebuild b/sys-apps/vbetool/vbetool-1.2.2.ebuild
new file mode 100644
index 000000000000..ecd6b7b6c7c1
--- /dev/null
+++ b/sys-apps/vbetool/vbetool-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Run real-mode video BIOS code to alter hw state (i.e. reinitialize video card)"
+HOMEPAGE="https://cgit.freedesktop.org/~airlied/vbetool/"
+SRC_URI="https://dev.gentoo.org/~ionen/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="selinux"
+
+DEPEND="
+ dev-libs/libx86
+ sys-libs/zlib:=
+ x11-libs/libpciaccess
+"
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-vbetool )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libx86.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}