summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild')
-rw-r--r--sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild
new file mode 100644
index 000000000000..c736e7c2628b
--- /dev/null
+++ b/sys-apps/xdg-dbus-proxy/xdg-dbus-proxy-0.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Filtering proxy for D-Bus connections"
+HOMEPAGE="https://github.com/flatpak/xdg-dbus-proxy"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dinstalled_tests=false
+ -Dman=enabled
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}