summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal-xapp')
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/metadata.xml15
-rw-r--r--sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild36
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-xapp/Manifest b/sys-apps/xdg-desktop-portal-xapp/Manifest
new file mode 100644
index 000000000000..f5ac5692e8a8
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-xapp-1.0.4.tar.gz 88429 BLAKE2B 7f45a252a5c0dd433238a58012c65369240e7974a93d3d2b5b73bdbc91509480977ad1ce381a6f4ee3a0c87bfabd11ce87bf99839018811a84378e54be1ef36f SHA512 3f861473a763c37a1af95e3beb13c3364a04f557310d5a6520845bc754941149eb3d80a4e2893699715ff11b135edb2859f6349b6aa6fbe0aa1e173263e22dba
diff --git a/sys-apps/xdg-desktop-portal-xapp/metadata.xml b/sys-apps/xdg-desktop-portal-xapp/metadata.xml
new file mode 100644
index 000000000000..47039577a973
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sparky@bluefang-logic.com</email>
+ <name>Matthew Turnbull</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">linuxmint/xdg-desktop-portal-xapp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild
new file mode 100644
index 000000000000..9d6c9bec552a
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-xapp/xdg-desktop-portal-xapp-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using Cinnamon/MATE/Xfce"
+HOMEPAGE="https://github.com/linuxmint/xdg-desktop-portal-xapp/"
+SRC_URI="https://github.com/linuxmint/xdg-desktop-portal-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=sys-apps/xdg-desktop-portal-1.5
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/xdg-desktop-portal-gtk
+ >=x11-libs/xapp-2.8.1
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ meson_src_configure
+}