summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/yarn/yarn-1.0.1.ebuild')
-rw-r--r--sys-apps/yarn/yarn-1.0.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/sys-apps/yarn/yarn-1.0.1.ebuild b/sys-apps/yarn/yarn-1.0.1.ebuild
deleted file mode 100644
index f028ad115d08..000000000000
--- a/sys-apps/yarn/yarn-1.0.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Fast, reliable, and secure node dependency management"
-HOMEPAGE="https://yarnpkg.com"
-SRC_URI="https://github.com/yarnpkg/yarn/releases/download/v${PV}/yarn-v${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="!dev-util/cmdtest
- net-libs/nodejs"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}-v${PV}
-
-src_install() {
- local install_dir="/usr/$(get_libdir)/node_modules/yarn" path
- insinto "${install_dir}"
- doins -r .
- dosym "../$(get_libdir)/node_modules/yarn/bin/yarn.js" "/usr/bin/yarn"
- fperms a+x "${install_dir}/bin/yarn.js"
- while read -r -d '' path; do
- [[ $(head -n1 "${path}") == \#\!* ]] || continue
- chmod +x "${path}" || die #614094
- done < <(find "${ED}" -type f -print0)
-}