summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.2.0.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.2.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
index cc81b3a08cbf..6156029daf1d 100644
--- a/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit pam
+inherit autotools pam
DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
@@ -22,8 +22,14 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-openssl11.patch" #658036
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf --with-pamdir="$(getpam_mod_dir)"
}