summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/fio/fio-1.17.2.ebuild')
-rw-r--r--sys-block/fio/fio-1.17.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/fio/fio-1.17.2.ebuild b/sys-block/fio/fio-1.17.2.ebuild
new file mode 100644
index 000000000000..1c4de44784e2
--- /dev/null
+++ b/sys-block/fio/fio-1.17.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ append-flags -W
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+}