summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/fio/fio-2.2.9.ebuild')
-rw-r--r--sys-block/fio/fio-2.2.9.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-block/fio/fio-2.2.9.ebuild b/sys-block/fio/fio-2.2.9.ebuild
index 32929cb63bfc..6af0f05c48d8 100644
--- a/sys-block/fio/fio-2.2.9.ebuild
+++ b/sys-block/fio/fio-2.2.9.ebuild
@@ -51,6 +51,7 @@ src_prepare() {
src_configure() {
chmod g-w "${T}"
# not a real configure script
+ set -- \
./configure \
--extra-cflags="${CFLAGS} ${CPPFLAGS}" \
--cc="$(tc-getCC)" \
@@ -58,8 +59,9 @@ src_configure() {
$(usex gtk '--enable-gfio' '') \
$(usex numa '' '--disable-numa') \
$(usex rbd '' '--disable-rbd') \
- $(usex static '--build-static' '') \
- || die 'configure failed'
+ $(usex static '--build-static' '')
+ echo "$@"
+ "$@" || die 'configure failed'
}
src_compile() {