summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbd/nbd-2.9.23.ebuild')
-rw-r--r--sys-block/nbd/nbd-2.9.23.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-2.9.23.ebuild b/sys-block/nbd/nbd-2.9.23.ebuild
new file mode 100644
index 000000000000..7f36380e502e
--- /dev/null
+++ b/sys-block/nbd/nbd-2.9.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog
+}
+
+src_compile() {
+ emake || die
+ emake -C gznbd || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dobin gznbd/gznbd || die
+ dodoc README
+}