summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbd/nbd-3.2.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.2.ebuild b/sys-block/nbd/nbd-3.2.ebuild
new file mode 100644
index 000000000000..b5512bd929ee
--- /dev/null
+++ b/sys-block/nbd/nbd-3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 ~sparc x86"
+IUSE="debug zlib"
+
+RDEPEND=">=dev-libs/glib-2.0
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ use zlib && emake -C gznbd CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ use zlib && dobin gznbd/gznbd
+}