summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/files/2.02-freetype-capitalise-variables.patch126
-rw-r--r--sys-boot/grub/files/2.02-freetype-pkg-config.patch225
-rw-r--r--sys-boot/grub/grub-2.02-r1.ebuild8
3 files changed, 301 insertions, 58 deletions
diff --git a/sys-boot/grub/files/2.02-freetype-capitalise-variables.patch b/sys-boot/grub/files/2.02-freetype-capitalise-variables.patch
new file mode 100644
index 000000000000..9aa7f54f32ab
--- /dev/null
+++ b/sys-boot/grub/files/2.02-freetype-capitalise-variables.patch
@@ -0,0 +1,126 @@
+From ba84c8d1b4830e9fcb14d9f0e4a36e03ac40a09d Mon Sep 17 00:00:00 2001
+From: Colin Watson <cjwatson@ubuntu.com>
+Date: Tue, 30 Jan 2018 14:08:26 +0000
+Subject: build: Capitalise *freetype_* variables
+
+Using FREETYPE_CFLAGS and FREETYPE_LIBS is more in line with the naming
+scheme used by pkg-config macros.
+
+Bug-Debian: https://bugs.debian.org/887721
+Last-Update: 2018-02-11
+
+Patch-Name: freetype-capitalise-variables.patch
+---
+ Makefile.am | 6 +++---
+ Makefile.util.def | 4 ++--
+ configure.ac | 24 ++++++++++++------------
+ 3 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index f0ab1adc3..b47b4b1ac 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -71,7 +71,7 @@ endif
+ starfield_theme_files = $(srcdir)/themes/starfield/blob_w.png $(srcdir)/themes/starfield/boot_menu_c.png $(srcdir)/themes/starfield/boot_menu_e.png $(srcdir)/themes/starfield/boot_menu_ne.png $(srcdir)/themes/starfield/boot_menu_n.png $(srcdir)/themes/starfield/boot_menu_nw.png $(srcdir)/themes/starfield/boot_menu_se.png $(srcdir)/themes/starfield/boot_menu_s.png $(srcdir)/themes/starfield/boot_menu_sw.png $(srcdir)/themes/starfield/boot_menu_w.png $(srcdir)/themes/starfield/slider_c.png $(srcdir)/themes/starfield/slider_n.png $(srcdir)/themes/starfield/slider_s.png $(srcdir)/themes/starfield/starfield.png $(srcdir)/themes/starfield/terminal_box_c.png $(srcdir)/themes/starfield/terminal_box_e.png $(srcdir)/themes/starfield/terminal_box_ne.png $(srcdir)/themes/starfield/terminal_box_n.png $(srcdir)/themes/starfield/terminal_box_nw.png $(srcdir)/themes/starfield/terminal_box_se.png $(srcdir)/themes/starfield/terminal_box_s.png $(srcdir)/themes/starfield/terminal_box_sw.png $(srcdir)/themes/starfield/terminal_box_w.png $(srcdir)/themes/starfield/theme.txt $(srcdir)/themes/starfield/README $(srcdir)/themes/starfield/COPYING.CC-BY-SA-3.0
+
+ build-grub-mkfont$(BUILD_EXEEXT): util/grub-mkfont.c grub-core/unidata.c grub-core/kern/emu/misc.c util/misc.c
+- $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 -DGRUB_BUILD_PROGRAM_NAME=\"build-grub-mkfont\" $^ $(build_freetype_cflags) $(build_freetype_libs)
++ $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 -DGRUB_BUILD_PROGRAM_NAME=\"build-grub-mkfont\" $^ $(BUILD_FREETYPE_CFLAGS) $(BUILD_FREETYPE_LIBS)
+ CLEANFILES += build-grub-mkfont$(BUILD_EXEEXT)
+
+ garbage-gen$(BUILD_EXEEXT): util/garbage-gen.c
+@@ -80,11 +80,11 @@ CLEANFILES += garbage-gen$(BUILD_EXEEXT)
+ EXTRA_DIST += util/garbage-gen.c
+
+ build-grub-gen-asciih$(BUILD_EXEEXT): util/grub-gen-asciih.c
+- $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 $^ $(build_freetype_cflags) $(build_freetype_libs) -Wall -Werror
++ $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 $^ $(BUILD_FREETYPE_CFLAGS) $(BUILD_FREETYPE_LIBS) -Wall -Werror
+ CLEANFILES += build-grub-gen-asciih$(BUILD_EXEEXT)
+
+ build-grub-gen-widthspec$(BUILD_EXEEXT): util/grub-gen-widthspec.c
+- $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 $^ $(build_freetype_cflags) $(build_freetype_libs) -Wall -Werror
++ $(BUILD_CC) -o $@ -I$(top_srcdir)/include $(BUILD_CFLAGS) $(BUILD_CPPFLAGS) $(BUILD_LDFLAGS) -DGRUB_MKFONT=1 -DGRUB_BUILD=1 -DGRUB_UTIL=1 $^ $(BUILD_FREETYPE_CFLAGS) $(BUILD_FREETYPE_LIBS) -Wall -Werror
+ CLEANFILES += build-grub-gen-widthspec$(BUILD_EXEEXT)
+
+ if COND_STARFIELD
+diff --git a/Makefile.util.def b/Makefile.util.def
+index 168acbe59..fa39d8bd1 100644
+--- a/Makefile.util.def
++++ b/Makefile.util.def
+@@ -302,14 +302,14 @@ program = {
+ common = grub-core/kern/emu/argp_common.c;
+ common = grub-core/osdep/init.c;
+
+- cflags = '$(freetype_cflags)';
++ cflags = '$(FREETYPE_CFLAGS)';
+ cppflags = '-DGRUB_MKFONT=1';
+
+ ldadd = libgrubmods.a;
+ ldadd = libgrubgcry.a;
+ ldadd = libgrubkern.a;
+ ldadd = grub-core/gnulib/libgnu.a;
+- ldadd = '$(freetype_libs)';
++ ldadd = '$(FREETYPE_LIBS)';
+ ldadd = '$(LIBINTL) $(LIBDEVMAPPER) $(LIBZFS) $(LIBNVPAIR) $(LIBGEOM)';
+ condition = COND_GRUB_MKFONT;
+ };
+diff --git a/configure.ac b/configure.ac
+index cd1f49837..85c23bd62 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1505,12 +1505,12 @@ unset ac_cv_header_ft2build_h
+
+ if test x"$grub_mkfont_excuse" = x ; then
+ # Check for freetype libraries.
+- freetype_cflags=`$FREETYPE --cflags`
+- freetype_libs=`$FREETYPE --libs`
++ FREETYPE_CFLAGS=`$FREETYPE --cflags`
++ FREETYPE_LIBS=`$FREETYPE --libs`
+ SAVED_CPPFLAGS="$CPPFLAGS"
+ SAVED_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS $freetype_cflags"
+- LIBS="$LIBS $freetype_libs"
++ CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
++ LIBS="$LIBS $FREETYPE_LIBS"
+ AC_CHECK_HEADERS([ft2build.h], [],
+ [grub_mkfont_excuse=["need freetype2 headers"]])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [], [grub_mkfont_excuse=["freetype2 library unusable"]])
+@@ -1527,8 +1527,8 @@ else
+ enable_grub_mkfont=no
+ fi
+ AC_SUBST([enable_grub_mkfont])
+-AC_SUBST([freetype_cflags])
+-AC_SUBST([freetype_libs])
++AC_SUBST([FREETYPE_CFLAGS])
++AC_SUBST([FREETYPE_LIBS])
+
+ SAVED_CC="$CC"
+ SAVED_CPP="$CPP"
+@@ -1566,12 +1566,12 @@ fi
+
+ if test x"$grub_build_mkfont_excuse" = x ; then
+ # Check for freetype libraries.
+- build_freetype_cflags=`$BUILD_FREETYPE --cflags`
+- build_freetype_libs=`$BUILD_FREETYPE --libs`
++ BUILD_FREETYPE_CFLAGS=`$BUILD_FREETYPE --cflags`
++ BUILD_FREETYPE_LIBS=`$BUILD_FREETYPE --libs`
+ SAVED_CPPFLAGS_2="$CPPFLAGS"
+ SAVED_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS $build_freetype_cflags"
+- LIBS="$LIBS $build_freetype_libs"
++ CPPFLAGS="$CPPFLAGS $BUILD_FREETYPE_CFLAGS"
++ LIBS="$LIBS $BUILD_FREETYPE_LIBS"
+ AC_CHECK_HEADERS([ft2build.h], [],
+ [grub_build_mkfont_excuse=["need freetype2 headers"]])
+ AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [], [grub_build_mkfont_excuse=["freetype2 library unusable"]])
+@@ -1595,8 +1595,8 @@ if test x"$enable_build_grub_mkfont" = xno && ( test "x$platform" = xqemu || tes
+ fi
+ fi
+
+-AC_SUBST([build_freetype_cflags])
+-AC_SUBST([build_freetype_libs])
++AC_SUBST([BUILD_FREETYPE_CFLAGS])
++AC_SUBST([BUILD_FREETYPE_LIBS])
+
+ CC="$SAVED_CC"
+ CPP="$SAVED_CPP"
diff --git a/sys-boot/grub/files/2.02-freetype-pkg-config.patch b/sys-boot/grub/files/2.02-freetype-pkg-config.patch
index bc2f91759bef..94437f073c4f 100644
--- a/sys-boot/grub/files/2.02-freetype-pkg-config.patch
+++ b/sys-boot/grub/files/2.02-freetype-pkg-config.patch
@@ -1,73 +1,194 @@
-From 3b0a266dead87906bcf440fd9ef12e1a514320ab Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 4 May 2018 13:43:59 +0200
-Subject: [PATCH] Use pkg-config to find freetype
+From 3eec911197081a63d9dae28f1784ad01a06fb60a Mon Sep 17 00:00:00 2001
+From: Colin Watson <cjwatson@ubuntu.com>
+Date: Tue, 30 Jan 2018 21:54:17 +0000
+Subject: build: Use pkg-config to find FreeType
-As of freetype-2.9.1 the freetype-config script has been deprecated and
-is no longer shipped by default.
+pkg-config is apparently preferred over freetype-config these days (see
+the BUGS section of freetype-config(1)). pkg-config support was added
+to FreeType in version 2.1.5, which was released in 2003, so it should
+comfortably be available everywhere by now.
-Based on a patch by Lars Wendler <polynomial-c@gentoo.org>.
+We no longer need to explicitly substitute FREETYPE_CFLAGS and
+FREETYPE_LIBS, since PKG_CHECK_MODULES does that automatically.
+
+Fixes Debian bug #887721.
+
+Reported-by: Hugh McMaster <hugh.mcmaster@outlook.com>
+Signed-off-by: Colin Watson <cjwatson@ubuntu.com>
+
+Bug-Debian: https://bugs.debian.org/887721
+Last-Update: 2018-02-11
+
+Patch-Name: freetype-pkg-config.patch
---
- configure.ac | 27 +++++++++++++++++++--------
- 1 file changed, 19 insertions(+), 8 deletions(-)
+ INSTALL | 11 +++++----
+ configure.ac | 74 +++++++++++++++++++++++++-----------------------------------
+ 2 files changed, 37 insertions(+), 48 deletions(-)
+diff --git a/INSTALL b/INSTALL
+index f3c20edc8..b370d7753 100644
+--- a/INSTALL
++++ b/INSTALL
+@@ -37,6 +37,7 @@ configuring the GRUB.
+ * GNU gettext 0.17 or later
+ * GNU binutils 2.9.1.0.23 or later
+ * Flex 2.5.35 or later
++* pkg-config
+ * Other standard GNU/Unix tools
+ * a libc with large file support (e.g. glibc 2.1 or later)
+
+@@ -52,7 +53,7 @@ For optional grub-emu features, you need:
+
+ To build GRUB's graphical terminal (gfxterm), you need:
+
+-* FreeType 2 or later
++* FreeType 2.1.5 or later
+ * GNU Unifont
+
+ If you use a development snapshot or want to hack on GRUB you may
+@@ -158,8 +159,8 @@ For this example the configure line might look like (more details below)
+ (some options are optional and included here for completeness but some rarely
+ used options are omitted):
+
+-./configure BUILD_CC=gcc BUILD_FREETYPE=freetype-config --host=amd64-linux-gnu
+-CC=amd64-linux-gnu-gcc CFLAGS="-g -O2" FREETYPE=amd64-linux-gnu-freetype-config
++./configure BUILD_CC=gcc BUILD_PKG_CONFIG=pkg-config --host=amd64-linux-gnu
++CC=amd64-linux-gnu-gcc CFLAGS="-g -O2" PKG_CONFIG=amd64-linux-gnu-pkg-config
+ --target=arm --with-platform=uboot TARGET_CC=arm-elf-gcc
+ TARGET_CFLAGS="-Os -march=armv6" TARGET_CCASFLAGS="-march=armv6"
+ TARGET_OBJCOPY="arm-elf-objcopy" TARGET_STRIP="arm-elf-strip"
+@@ -176,7 +177,7 @@ corresponding platform are not needed for the platform in question.
+ 2. BUILD_CFLAGS= for C options for build.
+ 3. BUILD_CPPFLAGS= for C preprocessor options for build.
+ 4. BUILD_LDFLAGS= for linker options for build.
+- 5. BUILD_FREETYPE= for freetype-config for build (optional).
++ 5. BUILD_PKG_CONFIG= for pkg-config for build (optional).
+
+ - For host
+ 1. --host= to autoconf name of host.
+@@ -184,7 +185,7 @@ corresponding platform are not needed for the platform in question.
+ 3. HOST_CFLAGS= for C options for host.
+ 4. HOST_CPPFLAGS= for C preprocessor options for host.
+ 5. HOST_LDFLAGS= for linker options for host.
+- 6. FREETYPE= for freetype-config for host (optional).
++ 6. PKG_CONFIG= for pkg-config for host (optional).
+ 7. Libdevmapper if any must be in standard linker folders (-ldevmapper) (optional).
+ 8. Libfuse if any must be in standard linker folders (-lfuse) (optional).
+ 9. Libzfs if any must be in standard linker folders (-lzfs) (optional).
diff --git a/configure.ac b/configure.ac
-index c7888e40f..220f5ffc1 100644
+index 85c23bd62..f102b7024 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1510,7 +1510,8 @@ fi
+@@ -50,6 +50,10 @@ AC_PREREQ(2.60)
+ AC_CONFIG_SRCDIR([include/grub/dl.h])
+ AC_CONFIG_HEADER([config-util.h])
- if test x"$grub_mkfont_excuse" = x ; then
- # Check for freetype libraries.
++# Explicitly check for pkg-config early on, since otherwise conditional
++# calls are problematic.
++PKG_PROG_PKG_CONFIG
++
+ # Program name transformations
+ AC_ARG_PROGRAM
+ grub_TRANSFORM([grub-bios-setup])
+@@ -1493,29 +1497,22 @@ if test x"$enable_grub_mkfont" = xno ; then
+ grub_mkfont_excuse="explicitly disabled"
+ fi
+
+-if test x"$grub_mkfont_excuse" = x ; then
+- # Check for freetype libraries.
- AC_CHECK_TOOLS([FREETYPE], [freetype-config])
-+ PKG_PROG_PKG_CONFIG
-+ PKG_CHECK_MODULES(FREETYPE2, freetype2, FREETYPE=yes)
- if test "x$FREETYPE" = x ; then
- grub_mkfont_excuse=["need freetype2 library"]
- fi
-@@ -1520,8 +1521,8 @@ unset ac_cv_header_ft2build_h
+- if test "x$FREETYPE" = x ; then
+- grub_mkfont_excuse=["need freetype2 library"]
+- fi
+-fi
+-
+ unset ac_cv_header_ft2build_h
if test x"$grub_mkfont_excuse" = x ; then
# Check for freetype libraries.
-- freetype_cflags=`$FREETYPE --cflags`
-- freetype_libs=`$FREETYPE --libs`
-+ freetype_cflags="$FREETYPE2_CFLAGS"
-+ freetype_libs="$FREETYPE2_LIBS"
- SAVED_CPPFLAGS="$CPPFLAGS"
- SAVED_LIBS="$LIBS"
- CPPFLAGS="$CPPFLAGS $freetype_cflags"
-@@ -1573,16 +1574,26 @@ AC_SUBST([BUILD_WORDS_BIGENDIAN])
+- FREETYPE_CFLAGS=`$FREETYPE --cflags`
+- FREETYPE_LIBS=`$FREETYPE --libs`
+- SAVED_CPPFLAGS="$CPPFLAGS"
+- SAVED_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
+- LIBS="$LIBS $FREETYPE_LIBS"
+- AC_CHECK_HEADERS([ft2build.h], [],
+- [grub_mkfont_excuse=["need freetype2 headers"]])
+- AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [], [grub_mkfont_excuse=["freetype2 library unusable"]])
+- CPPFLAGS="$SAVED_CPPFLAGS"
+- LIBS="$SAVED_LIBS"
++ PKG_CHECK_MODULES([FREETYPE], [freetype2], [
++ SAVED_CPPFLAGS="$CPPFLAGS"
++ SAVED_LIBS="$LIBS"
++ CPPFLAGS="$CPPFLAGS $FREETYPE_CFLAGS"
++ LIBS="$LIBS $FREETYPE_LIBS"
++ AC_CHECK_HEADERS([ft2build.h], [],
++ [grub_mkfont_excuse=["need freetype2 headers"]])
++ AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [],
++ [grub_mkfont_excuse=["freetype2 library unusable"]])
++ CPPFLAGS="$SAVED_CPPFLAGS"
++ LIBS="$SAVED_LIBS"
++ ], [grub_mkfont_excuse=["need freetype2 library"]])
+ fi
+
+ if test x"$enable_grub_mkfont" = xyes && test x"$grub_mkfont_excuse" != x ; then
+@@ -1527,8 +1524,6 @@ else
+ enable_grub_mkfont=no
+ fi
+ AC_SUBST([enable_grub_mkfont])
+-AC_SUBST([FREETYPE_CFLAGS])
+-AC_SUBST([FREETYPE_LIBS])
+
+ SAVED_CC="$CC"
+ SAVED_CPP="$CPP"
+@@ -1558,25 +1553,21 @@ AC_SUBST([BUILD_WORDS_BIGENDIAN])
if test x"$grub_build_mkfont_excuse" = x ; then
# Check for freetype libraries.
- AC_CHECK_PROGS([BUILD_FREETYPE], [freetype-config])
- if test "x$BUILD_FREETYPE" = x ; then
- grub_build_mkfont_excuse=["need freetype2 library"]
-+ if test -z "$BUILD_FREETYPE2_CFLAGS" || test -z "$BUILD_FREETYPE2_LIBS" ; then
-+ AC_CHECK_PROGS([BUILD_PKGCONFIG], [pkg-config])
-+ if test -z "$BUILD_PKGCONFIG" ; then
-+ grub_build_mkfont_excuse=["need pkg-config"]
-+ elif ! "$BUILD_PKGCONFIG" --exists freetype2 ; then
-+ grub_build_mkfont_excuse=["need freetype2 library"]
-+ fi
+- fi
+-fi
+-
+-if test x"$grub_build_mkfont_excuse" = x ; then
+- # Check for freetype libraries.
+- BUILD_FREETYPE_CFLAGS=`$BUILD_FREETYPE --cflags`
+- BUILD_FREETYPE_LIBS=`$BUILD_FREETYPE --libs`
+- SAVED_CPPFLAGS_2="$CPPFLAGS"
+- SAVED_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS $BUILD_FREETYPE_CFLAGS"
+- LIBS="$LIBS $BUILD_FREETYPE_LIBS"
+- AC_CHECK_HEADERS([ft2build.h], [],
+- [grub_build_mkfont_excuse=["need freetype2 headers"]])
+- AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [], [grub_build_mkfont_excuse=["freetype2 library unusable"]])
+- LIBS="$SAVED_LIBS"
+- CPPFLAGS="$SAVED_CPPFLAGS_2"
++ SAVED_PKG_CONFIG="$PKG_CONFIG"
++ test -z "$BUILD_PKG_CONFIG" || PKG_CONFIG="$BUILD_PKG_CONFIG"
++ PKG_CHECK_MODULES([BUILD_FREETYPE], [freetype2], [
++ SAVED_CPPFLAGS_2="$CPPFLAGS"
++ SAVED_LIBS="$LIBS"
++ CPPFLAGS="$CPPFLAGS $BUILD_FREETYPE_CFLAGS"
++ LIBS="$LIBS $BUILD_FREETYPE_LIBS"
++ AC_CHECK_HEADERS([ft2build.h], [],
++ [grub_build_mkfont_excuse=["need freetype2 headers"]])
++ AC_LINK_IFELSE([AC_LANG_CALL([], [FT_Load_Glyph])], [],
++ [grub_build_mkfont_excuse=["freetype2 library unusable"]])
++ LIBS="$SAVED_LIBS"
++ CPPFLAGS="$SAVED_CPPFLAGS_2"
++ ], [grub_build_mkfont_excuse=["need freetype2 library"]])
++ PKG_CONFIG="$SAVED_PKG_CONFIG"
+ fi
+
+ if test x"$enable_build_grub_mkfont" = xyes && test x"$grub_build_mkfont_excuse" != x ; then
+@@ -1595,9 +1586,6 @@ if test x"$enable_build_grub_mkfont" = xno && ( test "x$platform" = xqemu || tes
fi
fi
- if test x"$grub_build_mkfont_excuse" = x ; then
- # Check for freetype libraries.
-- build_freetype_cflags=`$BUILD_FREETYPE --cflags`
-- build_freetype_libs=`$BUILD_FREETYPE --libs`
-+ if test -z "$BUILD_FREETYPE2_CFLAGS" ; then
-+ BUILD_FREETYPE2_CFLAGS=`$BUILD_PKGCONFIG --cflags freetype2`
-+ fi
-+ if test -z "$BUILD_FREETYPE2_LIBS" ; then
-+ BUILD_FREETYPE2_LIBS=`$BUILD_PKGCONFIG --libs freetype2`
-+ fi
-+ build_freetype_cflags="$BUILD_FREETYPE2_CFLAGS"
-+ build_freetype_libs="$BUILD_FREETYPE2_LIBS"
- SAVED_CPPFLAGS_2="$CPPFLAGS"
- SAVED_LIBS="$LIBS"
- CPPFLAGS="$CPPFLAGS $build_freetype_cflags"
---
-2.17.0
-
+-AC_SUBST([BUILD_FREETYPE_CFLAGS])
+-AC_SUBST([BUILD_FREETYPE_LIBS])
+-
+ CC="$SAVED_CC"
+ CPP="$SAVED_CPP"
+ CFLAGS="$SAVED_CFLAGS"
diff --git a/sys-boot/grub/grub-2.02-r1.ebuild b/sys-boot/grub/grub-2.02-r1.ebuild
index a82ceccfbd20..d18b6e78cb68 100644
--- a/sys-boot/grub/grub-2.02-r1.ebuild
+++ b/sys-boot/grub/grub-2.02-r1.ebuild
@@ -3,12 +3,7 @@
EAPI=6
-if [[ ${PV} == 9999 ]]; then
- GRUB_AUTOGEN=1
- GRUB_AUTORECONF=1
-fi
-
-# 2.02-grub-pkg-config.patch modifies configure.ac
+GRUB_AUTOGEN=1
GRUB_AUTORECONF=1
if [[ -n ${GRUB_AUTOGEN} ]]; then
@@ -44,6 +39,7 @@ PATCHES=(
"${FILESDIR}"/gfxpayload.patch
"${FILESDIR}"/grub-2.02_beta2-KERNEL_GLOBS.patch
"${FILESDIR}"/2.02-multiple-early-initrd.patch
+ "${FILESDIR}"/2.02-freetype-capitalise-variables.patch
"${FILESDIR}"/2.02-freetype-pkg-config.patch
)