summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth/plymouth-9999.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 375f98aabb34..5ffedf306a90 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -3,13 +3,15 @@
EAPI=6
+inherit flag-o-matic
SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/plymouth"
inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/plymouth"
else
SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
inherit autotools readme.gentoo-r1 systemd toolchain-funcs
@@ -19,8 +21,6 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug gdm +gtk +libkms +pango static-libs"
CDEPEND="
@@ -28,11 +28,15 @@ CDEPEND="
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
- x11-libs/cairo )
+ x11-libs/cairo
+ )
libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
+ elibc_musl? ( sys-libs/rpmatch-standalone )
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
virtual/pkgconfig
"
# Block due bug #383067
@@ -51,6 +55,7 @@ PATCHES=(
)
src_prepare() {
+ use elibc_musl && append-ldflags -lrpmatch
default
eautoreconf
}
@@ -60,6 +65,7 @@ src_configure() {
--with-system-root-install=no
--localstatedir=/var
--without-rhgb-compat-link
+ --enable-documentation
--enable-systemd-integration
--with-systemdunitdir="$(systemd_get_systemunitdir)"
$(use_enable !static-libs shared)