summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/grub-2.04-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-2.04-r1.ebuild b/sys-boot/grub/grub-2.04-r1.ebuild
index 81bd769728c9..7135f70c7f98 100644
--- a/sys-boot/grub/grub-2.04-r1.ebuild
+++ b/sys-boot/grub/grub-2.04-r1.ebuild
@@ -55,7 +55,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -105,6 +105,7 @@ DEPEND="
ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
"
RDEPEND="${DEPEND}
kernel_linux? (
@@ -177,6 +178,7 @@ grub_configure() {
case ${MULTIBUILD_VARIANT} in
efi*) platform=efi ;;
+ xen-pvh) platform=xen_pvh ;;
xen*) platform=xen ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 07f21fac6705..6b165af82481 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -54,7 +54,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="device-mapper doc efiemu +fonts mount nls sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 xen-pvh )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -104,6 +104,7 @@ DEPEND="
ppc64? ( >=sys-apps/ibm-powerpc-utils-1.3.5 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
grub_platforms_xen-32? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-pvh? ( app-emulation/xen-tools:= )
"
RDEPEND="${DEPEND}
kernel_linux? (
@@ -176,6 +177,7 @@ grub_configure() {
case ${MULTIBUILD_VARIANT} in
efi*) platform=efi ;;
+ xen-pvh) platform=xen_pvh ;;
xen*) platform=xen ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;