summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/nomad/nomad-0.12.3.ebuild')
-rw-r--r--sys-cluster/nomad/nomad-0.12.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-cluster/nomad/nomad-0.12.3.ebuild b/sys-cluster/nomad/nomad-0.12.3.ebuild
index 52e0d90e0b58..e605fbb5f71d 100644
--- a/sys-cluster/nomad/nomad-0.12.3.ebuild
+++ b/sys-cluster/nomad/nomad-0.12.3.ebuild
@@ -12,12 +12,12 @@ SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="nvidia"
src_compile() {
local go_ldflags go_tags
go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated"
+ go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
CGO_ENABLED=1 \
go build \
-trimpath \