summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.13.4-r2.ebuild')
-rw-r--r--sys-devel/automake/automake-1.13.4-r2.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/sys-devel/automake/automake-1.13.4-r2.ebuild b/sys-devel/automake/automake-1.13.4-r2.ebuild
index cb464ade7c1f..21c2e6bf016e 100644
--- a/sys-devel/automake/automake-1.13.4-r2.ebuild
+++ b/sys-devel/automake/automake-1.13.4-r2.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1
+EAPI=7
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="https://www.gnu.org/software/automake/"
@@ -14,16 +11,16 @@ LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
+RESTRICT="test"
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-10
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
+ sys-apps/help2man"
+BDEPEND="app-arch/gzip"
PATCHES=(
"${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
@@ -32,10 +29,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.14-install-sh-avoid-low-risk-race-in-tmp.patch
)
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
src_prepare() {
default
export WANT_AUTOCONF=2.5
@@ -45,7 +38,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir || die
# Rewrite all the references to other pages.
@@ -75,16 +68,23 @@ src_install() {
default
slot_info_pages
- rm "${ED%/}"/usr/share/aclocal/README || die
- rmdir "${ED%/}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
rm \
- "${ED%/}"/usr/bin/{aclocal,automake} \
- "${ED%/}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
+
+ # Avoid QA message about pre-compressed file in docs
+ local tarfile="${ED}/usr/share/doc/${PF}/amhello-1.0.tar.gz"
+ if [[ -f "${tarfile}" ]] ; then
+ gunzip "${tarfile}" || die
+ fi
}