summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.16.1-r1.ebuild')
-rw-r--r--sys-devel/automake/automake-1.16.1-r1.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/sys-devel/automake/automake-1.16.1-r1.ebuild b/sys-devel/automake/automake-1.16.1-r1.ebuild
index 4a5093369fe7..fb84f2113fed 100644
--- a/sys-devel/automake/automake-1.16.1-r1.ebuild
+++ b/sys-devel/automake/automake-1.16.1-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-any-r1 versionator
+EAPI=7
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/r/${PN}.git"
@@ -17,7 +14,7 @@ else
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
https://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.xz"
else
- MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_PV="$(ver_cut 1).$(($(ver_cut 2)-1))b"
MY_P="${PN}-${MY_PV}"
# Alpha/beta releases are not distributed on the usual mirrors.
@@ -32,20 +29,15 @@ HOMEPAGE="https://www.gnu.org/software/automake/"
LICENSE="GPL-2"
# Use Gentoo versioning for slotting.
SLOT="${PV:0:4}"
-IUSE="test"
-RESTRICT="!test? ( test )"
+IUSE=""
+RESTRICT="test"
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-11
>=sys-devel/autoconf-2.69:*
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
- sys-apps/help2man
- test? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
+ sys-apps/help2man"
src_prepare() {
default
@@ -64,7 +56,7 @@ src_prepare() {
# slot the info pages. do this w/out munging the source so we don't have
# to depend on texinfo to regen things. #464146 (among others)
slot_info_pages() {
- pushd "${ED%/}"/usr/share/info >/dev/null || die
+ pushd "${ED}"/usr/share/info >/dev/null || die
rm -f dir || die
# Rewrite all the references to other pages.
@@ -94,16 +86,17 @@ src_install() {
default
slot_info_pages
- rm "${ED%/}"/usr/share/aclocal/README || die
- rmdir "${ED%/}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/aclocal/README || die
+ rmdir "${ED}"/usr/share/aclocal || die
rm \
- "${ED%/}"/usr/bin/{aclocal,automake} \
- "${ED%/}"/usr/share/man/man1/{aclocal,automake}.1 || die
+ "${ED}"/usr/bin/{aclocal,automake} \
+ "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
local x
for x in guess sub ; do
- dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ dosym ../gnuconfig/config.${x} \
+ /usr/share/${PN}-${SLOT}/config.${x}
done
}