summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-10.2.1_pre9999.ebuild')
-rw-r--r--sys-devel/gcc/gcc-10.2.1_pre9999.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-10.2.1_pre9999.ebuild b/sys-devel/gcc/gcc-10.2.1_pre9999.ebuild
index 16a7ee805039..5a5beeba49e7 100644
--- a/sys-devel/gcc/gcc-10.2.1_pre9999.ebuild
+++ b/sys-devel/gcc/gcc-10.2.1_pre9999.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PATCH_GCC_VER="10.2.0" # reuse subset of patches for latest for live ebuilds gcc
-PATCH_VER="1"
+PATCH_VER="2"
inherit toolchain
@@ -13,3 +13,18 @@ inherit toolchain
RDEPEND=""
BDEPEND="${CATEGORY}/binutils"
+
+src_prepare() {
+ local p upstreamed_patches=(
+ 32_all_sparc_pie_TEXTREL.patch
+ 33_all_lto-O0-mix-ICE-ipa-PR96291.patch
+ 35_all_ipa-fix-bit-CP.patch
+ 36_all_ipa-fix-bit-CP-p2.patch
+ )
+
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/$p" || die
+ done
+
+ toolchain_src_prepare
+}