summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/qconf/qconf-1.5_pre717-r1.ebuild')
-rw-r--r--sys-devel/qconf/qconf-1.5_pre717-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
new file mode 100644
index 000000000000..a7b8ac604e0f
--- /dev/null
+++ b/sys-devel/qconf/qconf-1.5_pre717-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit multilib qt4-r2
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="http://delta.affinix.com/qconf/"
+SRC_URI="http://delta.affinix.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Fake ./configure. Fails on unknown options
+ ./configure \
+ --prefix=/usr/ \
+ --qtdir=/usr/$(get_libdir)/ || die "./configure failed"
+
+ [ ! -f Makefile ] && die "./configure failed"
+
+ eqmake4
+}
+
+src_install() {
+ dobin qconf || die
+ dodoc README TODO || die
+ insinto /usr/share/${PN}
+ doins -r conf modules
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+}