summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/vgabios/vgabios-0.7a-r1.ebuild')
-rw-r--r--sys-firmware/vgabios/vgabios-0.7a-r1.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild b/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
index 081c30ad69c8..84a7f9b665bc 100644
--- a/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
+++ b/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
# Can't really call them backports when they're fixes that upstream
# won't carry
FIXES=1
-inherit eutils
-
DESCRIPTION="VGA BIOS implementation"
HOMEPAGE="http://www.nongnu.org/vgabios/"
SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz
@@ -16,18 +14,16 @@ SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
IUSE="binary debug"
-
-DEPEND="!binary? ( sys-devel/dev86 )"
-RDEPEND=""
+BDEPEND="!binary? ( sys-devel/dev86 )"
src_prepare() {
- [[ -n ${FIXES} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
+ if [[ -n ${FIXES} ]] ; then
+ eapply patches/*.patch
+ fi
- epatch_user
+ default
}
src_compile() {