summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ctmg/ctmg-1.1.ebuild')
-rw-r--r--sys-fs/ctmg/ctmg-1.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/ctmg/ctmg-1.1.ebuild b/sys-fs/ctmg/ctmg-1.1.ebuild
new file mode 100644
index 000000000000..30dd4d44a918
--- /dev/null
+++ b/sys-fs/ctmg/ctmg-1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Simple wrapper around cryptsetup for encrypted containers"
+HOMEPAGE="http://git.zx2c4.com/ctmg/about/"
+SRC_URI="http://git.zx2c4.com/${PN}/snapshot/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-fs/cryptsetup sys-apps/util-linux sys-fs/e2fsprogs sys-apps/coreutils app-admin/sudo"
+
+src_compile() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}