summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/e2tools')
-rw-r--r--sys-fs/e2tools/Manifest1
-rw-r--r--sys-fs/e2tools/e2tools-0.1.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/sys-fs/e2tools/Manifest b/sys-fs/e2tools/Manifest
index 7dc2be92e9fc..42482eeaaf4d 100644
--- a/sys-fs/e2tools/Manifest
+++ b/sys-fs/e2tools/Manifest
@@ -1 +1,2 @@
DIST e2tools-0.0.16.4.tar.gz 70444 BLAKE2B 3db75ca2ecca27bfbd65890f595c9523f373555e771f21113ca1c3bd1f08d74f5e1d70db39bbe0ac215a1766e702a37c2c2752f671320d45f3bfa56b39fd8296 SHA512 35bda0005d0ba4d9541eabf45bd9bed0e7e85144dce88c3bd8afd8eb5ed5db610bc5654aee82978b2a4955d363fd5af4ff40667fa8001955267c96cb84e6792b
+DIST e2tools-0.1.0.tar.gz 243245 BLAKE2B 62a1e478b71e9105274ba8b815f1f4765ecc05593de481c4ef384ff9463a0be811efe5f37bd3509393dfd3bdfb0103625e192ebcce52cbf896a6f7758cb50884 SHA512 5fde992727946d253acd46987944bdf49615d2ab45bbea715c86b304d117c6900dd70fcffb093f3d564247e27978b78b4710e7fea7ffd28375e804955fe4d5c9
diff --git a/sys-fs/e2tools/e2tools-0.1.0.ebuild b/sys-fs/e2tools/e2tools-0.1.0.ebuild
new file mode 100644
index 000000000000..0f866011f863
--- /dev/null
+++ b/sys-fs/e2tools/e2tools-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
+HOMEPAGE="https://github.com/ndim/e2tools"
+SRC_URI="https://github.com/e2tools/e2tools/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export CC
+ default
+}