summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
index 8339d3420ba3..1962c02d2f22 100644
--- a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
@@ -66,9 +66,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"