summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/bbswitch/bbswitch-9999.ebuild')
-rw-r--r--sys-power/bbswitch/bbswitch-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-power/bbswitch/bbswitch-9999.ebuild b/sys-power/bbswitch/bbswitch-9999.ebuild
index ad44354463cd..7efe9cf7ccdc 100644
--- a/sys-power/bbswitch/bbswitch-9999.ebuild
+++ b/sys-power/bbswitch/bbswitch-9999.ebuild
@@ -1,16 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-mod
+inherit linux-mod toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Bumblebee-Project/${PN}.git"
EGIT_BRANCH="develop"
else
- PATCHES=( "${FILESDIR}/${PN}-0.8-kernel-4.12.patch" )
+ PATCHES=(
+ "${FILESDIR}/${PN}-0.8-kernel-4.12.patch"
+ "${FILESDIR}/${PN}-0.8-kernel-5.6.patch"
+ )
SRC_URI="https://github.com/Bumblebee-Project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -34,7 +37,7 @@ pkg_setup() {
linux-mod_pkg_setup
BUILD_TARGETS="default"
- BUILD_PARAMS="KVERSION=${KV_FULL}"
+ BUILD_PARAMS="KVERSION=${KV_FULL} CC=$(tc-getCC)"
}
src_prepare() {