summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild')
-rw-r--r--www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild b/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
index eb30ac30836f..77ed113988e8 100644
--- a/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
+++ b/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
@@ -161,11 +161,14 @@ src_install() {
newbin "${FILESDIR}"/firefox-bin-wayland.sh ${PN}-wayland
;;
X11)
- exec_command="${PN}-x11 --name ${PN}-x11"
- if use wayland ; then
- # Only needed when there's actually a choice
- newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
+ if ! use wayland ; then
+ # Exit loop here because there's no choice so
+ # we don't need wrapper/.desktop file for X11.
+ continue
fi
+
+ exec_command="${PN}-x11 --name ${PN}-x11"
+ newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
;;
*)
app_name="${name}"