summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/opera/Manifest1
-rw-r--r--www-client/opera/opera-83.0.4254.54.ebuild158
2 files changed, 0 insertions, 159 deletions
diff --git a/www-client/opera/Manifest b/www-client/opera/Manifest
index 29b8abd08f35..77b0ca298239 100644
--- a/www-client/opera/Manifest
+++ b/www-client/opera/Manifest
@@ -1,3 +1,2 @@
DIST opera-ffmpeg-codecs-96.0.4655.7.tar.xz 1394152 BLAKE2B a48c1f22b5e92e40d8d5f97f02505021824823796767c1725c821b171b3ff6bf281d0123bf0b7e336f4d81b84bbf9362c6489f30b7de7c2037238c53003d6e00 SHA512 7c6815936e9a027d278a893e90e30f28a3d011ec83723c6500bee7ba0dddc5c96ae3cd75d7e16f7bbd2f9ee635fb64bdba6c2ba1df32761a6215be6eb3d5ec5c
-DIST opera-stable_83.0.4254.54_amd64.deb 79666988 BLAKE2B e1c198ef9d77309e487058229059fa513770c247aa22d6483256898bcb732566057f1b6b4ff06f5859d3e385825e335d05bfcaf9a557b91e20ceed91e3d107d9 SHA512 2ce8279d3efc7de6634023a64e69b54fc9d3b0386d9492194bfb80508b12d5c6cc3fb3c666121c79c38479701167f013c8ac2909a3cadb8c17b29b90e907fa05
DIST opera-stable_83.0.4254.62_amd64.deb 79674568 BLAKE2B b70efad1acdccb32a11634e1a236aaa9f617684213a361fb88ba9631693adfd482bd9dd22966c5a9b927a626aafa201686c25b030b3a09d85c6768ddd5baeb6c SHA512 cafe87830b8f2a7da264548468f82c07fc4d9714d0bc7eb71890b61b90e627438a04ffebe54646a44b5e143d63a324e3110a24911ecad12883dad2e47c4281be
diff --git a/www-client/opera/opera-83.0.4254.54.ebuild b/www-client/opera/opera-83.0.4254.54.ebuild
deleted file mode 100644
index 86c49da94643..000000000000
--- a/www-client/opera/opera-83.0.4254.54.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-CHROMIUM_LANGS="
- be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
- it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
- zh-CN zh-TW
-"
-
-# These are intended for ebuild maintainer use to force RPM if DEB is not available.
-: ${OPERA_FORCE_RPM=no}
-
-inherit chromium-2 pax-utils xdg
-
-if [[ ${OPERA_FORCE_RPM} == yes ]]; then
- inherit rpm
- OPERA_ARCHIVE_EXT="rpm"
-else
- inherit unpacker
- OPERA_ARCHIVE_EXT="deb"
-fi
-
-DESCRIPTION="A fast and secure web browser"
-HOMEPAGE="https://www.opera.com/"
-LICENSE="OPERA-2018"
-SLOT="0"
-
-SRC_URI_BASE=(
- "https://download1.operacdn.com/pub/${PN}"
- "https://download2.operacdn.com/pub/${PN}"
- "https://download3.operacdn.com/pub/${PN}"
- "https://download4.operacdn.com/pub/${PN}"
-)
-
-if [[ ${PN} == opera ]]; then
- MY_PN=${PN}-stable
- SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
-else
- MY_PN=${PN}
-fi
-
-KEYWORDS="-* amd64"
-
-FFMPEG_VERSION="96.0.4655.7"
-
-SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}
- proprietary-codecs? (
- mirror+https://dev.gentoo.org/~sultan/distfiles/www-client/opera/opera-ffmpeg-codecs-${FFMPEG_VERSION}.tar.xz
- )"
-
-IUSE="+proprietary-codecs suid"
-RESTRICT="bindist mirror strip"
-
-RDEPEND="
- app-accessibility/at-spi2-atk:2
- app-accessibility/at-spi2-core:2
- dev-libs/atk
- dev-libs/expat
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- gnome-base/gsettings-desktop-schemas
- media-libs/alsa-lib
- media-libs/mesa[gbm(+)]
- net-misc/curl
- net-print/cups
- sys-apps/dbus
- sys-libs/glibc
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:3
- x11-libs/libdrm
- x11-libs/libxcb
- x11-libs/libxkbcommon
- x11-libs/libxshmfence
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/pango
-"
-
-QA_PREBUILT="*"
-S=${WORKDIR}
-OPERA_HOME="opt/opera${PN#opera}"
-
-pkg_pretend() {
- # Protect against people using autounmask overzealously
- use amd64 || die "opera only works on amd64"
-}
-
-pkg_setup() {
- chromium_suid_sandbox_check_kernel_config
-}
-
-src_unpack() {
- :
-}
-
-src_install() {
- dodir /
- cd "${ED}" || die
- if [[ ${OPERA_FORCE_RPM} == yes ]]; then
- rpm_src_unpack "${A[0]}"
- else
- unpacker
- fi
-
- # move to /opt, bug #573052
- mkdir -p "${OPERA_HOME%${PN}}"
- if [[ ${OPERA_FORCE_RPM} == yes ]]; then
- mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
- else
- mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
- fi
- rm -r "usr/lib" || die
-
- # disable auto update
- rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
-
- if [[ ${OPERA_FORCE_RPM} == yes ]]; then
- rm "${OPERA_HOME}/setup_repo.sh" || die
- else
- rm -r "usr/share/lintian" || die
-
- # fix docs
- mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
- gzip -d usr/share/doc/${PF}/changelog.gz || die
- fi
-
- # fix desktop file
- sed -i \
- -e 's|^TargetEnvironment|X-&|g' \
- usr/share/applications/${PN}.desktop || die
-
- # remove unused language packs
- pushd "${OPERA_HOME}/localization" > /dev/null || die
- chromium_remove_language_paks
- popd > /dev/null || die
-
- # setup opera symlink
- rm "usr/bin/${PN}" || die
- dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
-
- # install proprietary codecs
- rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
- if use proprietary-codecs; then
- mv lib_extra "${OPERA_HOME}"
- fi
-
- # pax mark opera, bug #562038
- pax-mark m "${OPERA_HOME}/opera"
- # enable suid sandbox if requested
- use suid && fperms 4711 "${OPERA_HOME}/opera_sandbox"
-}