summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/fcgiwrap/fcgiwrap-9999.ebuild')
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-misc/fcgiwrap/fcgiwrap-9999.ebuild b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
new file mode 100644
index 000000000000..bb2ab67b6f43
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git-2" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="58ec209"
+ #SRC_URI="http://download.github.com/gnosek-${P}-4-g${MY_REV}.tar.gz"
+ SRC_URI="mirror://gentoo/${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst )
+
+src_prepare() {
+ sed -e "s/-Werror//" \
+ -i configure.ac || die "sed failed"
+
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}