summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/passff/passff-1.9.ebuild')
-rw-r--r--www-plugins/passff/passff-1.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-plugins/passff/passff-1.9.ebuild b/www-plugins/passff/passff-1.9.ebuild
new file mode 100644
index 000000000000..d2745055d54f
--- /dev/null
+++ b/www-plugins/passff/passff-1.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_XPINAME="${P}-fx"
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/3051801/${MY_XPINAME}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="www-plugins/passff-host[firefox]"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
+}
+
+src_install() {
+ # See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
+ insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
+ # passff@invicem.pro is the extension id found in the manifest.json
+ newins "${MY_XPINAME}.xpi" "passff@invicem.pro.xpi"
+}