summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/passff')
-rw-r--r--www-plugins/passff/Manifest1
-rw-r--r--www-plugins/passff/passff-1.6.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
index 3aeb03fe3463..a238c54bd06f 100644
--- a/www-plugins/passff/Manifest
+++ b/www-plugins/passff/Manifest
@@ -1 +1,2 @@
DIST passff-1.5.1-an+fx-linux.xpi 64094 BLAKE2B ebe19e26db05ca38f7ede9a01c1abaec786c197c6a25f0f144be903a93b85723bd143ad1805090fcfe81e83289a156f818d7b7b2a5462f151eb0ac12d1e82b0e SHA512 23dc3833c2d83181c21955169e5f65df88a4a26ab018a852d1181b84fd338a40f46b8ed5828f0e1fccca72f610facac68ceb766a3a7b454962228c36bde233f7
+DIST passff-1.6.3-fx.xpi 66124 BLAKE2B 9638567e141f0bc68d754325df2bc97a45f918778bddf536ccf9b5701a7e805f0081f8cd1c4193cd750c079b7e00880872cecb71324fd7267fe39638f4c46a9a SHA512 83dffe2b2f1284d90c6e37b5e794e45cc8e2e59f782ee0cce37da4bf16a6349f645e5fb59516bf5a10ef6a9e77a775cd81e4e775fb45b8a8454c9db4c0b781b5
diff --git a/www-plugins/passff/passff-1.6.3.ebuild b/www-plugins/passff/passff-1.6.3.ebuild
new file mode 100644
index 000000000000..884acd904a95
--- /dev/null
+++ b/www-plugins/passff/passff-1.6.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mozextension
+
+MY_XPINAME="${P}-fx"
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/1681210/${MY_XPINAME}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firefox firefox-bin"
+
+RDEPEND="www-plugins/passff-host[firefox]"
+REQUIRED_USE="|| ( firefox firefox-bin )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ xpi_unpack "${MY_XPINAME}.xpi"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ if use firefox; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${MY_XPINAME}"
+ fi
+
+ if use firefox-bin; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${MY_XPINAME}"
+ fi
+}