summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/pipelight')
-rw-r--r--www-plugins/pipelight/Manifest2
-rw-r--r--www-plugins/pipelight/metadata.xml11
-rw-r--r--www-plugins/pipelight/pipelight-0.2.7.3.ebuild87
-rw-r--r--www-plugins/pipelight/pipelight-0.2.8.ebuild87
-rw-r--r--www-plugins/pipelight/pipelight-9999.ebuild88
5 files changed, 275 insertions, 0 deletions
diff --git a/www-plugins/pipelight/Manifest b/www-plugins/pipelight/Manifest
new file mode 100644
index 000000000000..6a74563e0711
--- /dev/null
+++ b/www-plugins/pipelight/Manifest
@@ -0,0 +1,2 @@
+DIST pipelight-0.2.7.3.tar.gz 161967 SHA256 db4585f44874c0b647e7cf611b5bf8efe308fe11573891cd74dd4fa5867e2e52 SHA512 162b5f95b30c022a7f3bd821c7ba8e8af33ef0a4e2f38dff6a5da0a36725251a45b07c22c827c5a97b2320e395391f8d5c6702d3ed596e7cf66b064b2f9c8285 WHIRLPOOL 435bfb3f4fcb63b15af078da4765b0b0f1200e4691dcb3b92360cfda5f70f23c76458ff849c4a54ffab3f3f75c8d475c86c7ede6127cd57e6d34c50e1d07c367
+DIST pipelight-0.2.8.tar.gz 153492 SHA256 ae543d6eb95b3f681bf5807de63208e42c3be2ada1d2661017ad3a215c0684c4 SHA512 927fea510912879d0c976a20088dbbbadb3a1185e248d9a2ebb0afc4219bf4bcf4691f1ada678f4ccd24ea722e108615a04764ba664d66a6e03855aa663ae373 WHIRLPOOL 16d9b8460cb1d0f00097cf92d9c4d010a3f18b4d0c8c667b03b3b613bb80931b6fcf3d19d2ee96ae405375ee60e72aa4d6e84b9137ace7c7ac7d4d139e41eaff
diff --git a/www-plugins/pipelight/metadata.xml b/www-plugins/pipelight/metadata.xml
new file mode 100644
index 000000000000..e72ebc43b805
--- /dev/null
+++ b/www-plugins/pipelight/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">pipelight</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-plugins/pipelight/pipelight-0.2.7.3.ebuild b/www-plugins/pipelight/pipelight-0.2.7.3.ebuild
new file mode 100644
index 000000000000..fcd901a9c718
--- /dev/null
+++ b/www-plugins/pipelight/pipelight-0.2.7.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
+HOMEPAGE="https://launchpad.net/pipelight"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ gnome-extra/zenity"
+
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
+ usr/share/pipelight/winecheck.exe"
+
+src_configure() {
+ econf --wine-path="${EPREFIX}/usr/bin/wine"
+}
+
+src_install() {
+ default_src_install
+
+ # Ideally, every wrapped plugin could be a symlink to pipelight's wrapper
+ # plugin, but some browsers do not like this. Upstream provides a script to
+ # duplicate the wrapper plugin as a hack to work around it. That script
+ # does not support DESTDIR, so we use sed to adjust it before running it to
+ # properly duplicate the plugins.
+ # XXX: Patch the script to support DESTDIR and send the patch upstream.
+ sed -e "s:^\(PIPELIGHT_LIBRARY_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ -e "s:^\(PLUGIN_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ "${ED}/usr/bin/pipelight-plugin" > "${T}/pipelight-plugin" \
+ || die "Generating temporary pipelight-plugin failed"
+ chmod u+x "${T}/pipelight-plugin" \
+ || die "Setting permissions on temporary pipelight-plugin failed"
+
+ # Create Plugins
+ "${T}/pipelight-plugin" --create-mozilla-plugins \
+ || die "Creating plugins failed"
+
+}
+
+postinst() {
+ # Obligatory warnings about proprietary software
+ ewarn "Neither the Gentoo developers nor the Pipelight developers can"
+ ewarn "patch security vulnerabilities in Windows plugins. Use them at your"
+ ewarn "own risk."
+ # Warn about missing pipelight-sandbox
+ ewarn
+ ewarn "The pipelight sandbox has not been packaged yet. Plugins will have"
+ ewarn "full privileges as Windows programs running inside wine."
+
+ # Helpful information for those willing to live dangerously
+ einfo "Using Windows plugins on certain websites might require a useragent"
+ einfo "switcher. See the upstream tutorial for more details."
+ einfo
+ einfo "http://www.pipelight.net/cms/installation-user-agent.html"
+ einfo
+ einfo "End users should use the pipelight-plugin utility to install and"
+ einfo "manage plugins. Updates are done at plugin initialization whenever"
+ einfo "/usr/share/pipelight/install-dependency has been updated. This can"
+ einfo "be done either by doing updates via portage or by running"
+ einfo "pipelight-plugin --update as root. Browsers like Chrome (all"
+ einfo "versions before 35) will initialize plugins at boot while browsers"
+ einfo "like Firefox will initialize plugins on demand."
+ einfo
+ # Users must be in the video group for video acceleration
+ einfo "Membership in the video group is required for using plugins that"
+ einfo "feature hardware acceleration for video decoding. This is important"
+ einfo "for video streaming sites that use Silverlight."
+}
diff --git a/www-plugins/pipelight/pipelight-0.2.8.ebuild b/www-plugins/pipelight/pipelight-0.2.8.ebuild
new file mode 100644
index 000000000000..54746af60ca2
--- /dev/null
+++ b/www-plugins/pipelight/pipelight-0.2.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
+HOMEPAGE="https://launchpad.net/pipelight"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
+SLOT="0"
+IUSE=""
+
+DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ gnome-extra/zenity"
+
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
+ usr/share/pipelight/winecheck.exe"
+
+src_configure() {
+ econf --wine-path="${EPREFIX}/usr/bin/wine"
+}
+
+src_install() {
+ default_src_install
+
+ # Ideally, every wrapped plugin could be a symlink to pipelight's wrapper
+ # plugin, but some browsers do not like this. Upstream provides a script to
+ # duplicate the wrapper plugin as a hack to work around it. That script
+ # does not support DESTDIR, so we use sed to adjust it before running it to
+ # properly duplicate the plugins.
+ # XXX: Patch the script to support DESTDIR and send the patch upstream.
+ sed -e "s:^\(PIPELIGHT_LIBRARY_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ -e "s:^\(PLUGIN_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ "${ED}/usr/bin/pipelight-plugin" > "${T}/pipelight-plugin" \
+ || die "Generating temporary pipelight-plugin failed"
+ chmod u+x "${T}/pipelight-plugin" \
+ || die "Setting permissions on temporary pipelight-plugin failed"
+
+ # Create Plugins
+ "${T}/pipelight-plugin" --create-mozilla-plugins \
+ || die "Creating plugins failed"
+
+}
+
+postinst() {
+ # Obligatory warnings about proprietary software
+ ewarn "Neither the Gentoo developers nor the Pipelight developers can"
+ ewarn "patch security vulnerabilities in Windows plugins. Use them at your"
+ ewarn "own risk."
+ # Warn about missing pipelight-sandbox
+ ewarn
+ ewarn "The pipelight sandbox has not been packaged yet. Plugins will have"
+ ewarn "full privileges as Windows programs running inside wine."
+
+ # Helpful information for those willing to live dangerously
+ einfo "Using Windows plugins on certain websites might require a useragent"
+ einfo "switcher. See the upstream tutorial for more details."
+ einfo
+ einfo "http://www.pipelight.net/cms/installation-user-agent.html"
+ einfo
+ einfo "End users should use the pipelight-plugin utility to install and"
+ einfo "manage plugins. Updates are done at plugin initialization whenever"
+ einfo "/usr/share/pipelight/install-dependency has been updated. This can"
+ einfo "be done either by doing updates via portage or by running"
+ einfo "pipelight-plugin --update as root. Browsers like Chrome (all"
+ einfo "versions before 35) will initialize plugins at boot while browsers"
+ einfo "like Firefox will initialize plugins on demand."
+ einfo
+ # Users must be in the video group for video acceleration
+ einfo "Membership in the video group is required for using plugins that"
+ einfo "feature hardware acceleration for video decoding. This is important"
+ einfo "for video streaming sites that use Silverlight."
+}
diff --git a/www-plugins/pipelight/pipelight-9999.ebuild b/www-plugins/pipelight/pipelight-9999.ebuild
new file mode 100644
index 000000000000..8f1557d50051
--- /dev/null
+++ b/www-plugins/pipelight/pipelight-9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ EGIT_REPO_URI="https://bitbucket.org/mmueller2012/${PN}.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://bitbucket.org/mmueller2012/${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Wine-based wrapper for running Windows plugins on POSIX systems"
+HOMEPAGE="https://launchpad.net/pipelight"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1+ MPL-1.1 )"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="app-emulation/wine[X,abi_x86_32,pipelight]"
+RDEPEND="${DEPEND}
+ app-arch/cabextract
+ gnome-extra/zenity"
+
+QA_FLAGS_IGNORED="usr/share/pipelight/pluginloader.exe
+ usr/share/pipelight/winecheck.exe"
+
+src_configure() {
+ econf --wine-path="${EPREFIX}/usr/bin/wine"
+}
+
+src_install() {
+ default_src_install
+
+ # Ideally, every wrapped plugin could be a symlink to pipelight's wrapper
+ # plugin, but some browsers do not like this. Upstream provides a script to
+ # duplicate the wrapper plugin as a hack to work around it. That script
+ # does not support DESTDIR, so we use sed to adjust it before running it to
+ # properly duplicate the plugins.
+ # XXX: Patch the script to support DESTDIR and send the patch upstream.
+ sed -e "s:^\(PIPELIGHT_LIBRARY_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ -e "s:^\(PLUGIN_PATH=\"\)\\(.*\):\1${ED}usr/$(get_libdir)/${PN}\":" \
+ "${ED}/usr/bin/pipelight-plugin" > "${T}/pipelight-plugin" \
+ || die "Generating temporary pipelight-plugin failed"
+ chmod u+x "${T}/pipelight-plugin" \
+ || die "Setting permissions on temporary pipelight-plugin failed"
+
+ # Create Plugins
+ "${T}/pipelight-plugin" --create-mozilla-plugins \
+ || die "Creating plugins failed"
+
+}
+
+postinst() {
+ # Obligatory warnings about proprietary software
+ ewarn "Neither the Gentoo developers nor the Pipelight developers can"
+ ewarn "patch security vulnerabilities in Windows plugins. Use them at your"
+ ewarn "own risk."
+ # Warn about missing pipelight-sandbox
+ ewarn
+ ewarn "The pipelight sandbox has not been packaged yet. Plugins will have"
+ ewarn "full privileges as Windows programs running inside wine."
+
+ # Helpful information for those willing to live dangerously
+ einfo "Using Windows plugins on certain websites might require a useragent"
+ einfo "switcher. See the upstream tutorial for more details."
+ einfo
+ einfo "http://www.pipelight.net/cms/installation-user-agent.html"
+ einfo
+ einfo "End users should use the pipelight-plugin utility to install and"
+ einfo "manage plugins. Updates are done at plugin initialization whenever"
+ einfo "/usr/share/pipelight/install-dependency has been updated. This can"
+ einfo "be done either by doing updates via portage or by running"
+ einfo "pipelight-plugin --update as root. Browsers like Chrome (all"
+ einfo "versions before 35) will initialize plugins at boot while browsers"
+ einfo "like Firefox will initialize plugins on demand."
+ einfo
+ # Users must be in the video group for video acceleration
+ einfo "Membership in the video group is required for using plugins that"
+ einfo "feature hardware acceleration for video decoding. This is important"
+ einfo "for video streaming sites that use Silverlight."
+}